MozillaZine

Windows 98/ME not supported - Sunbird

From MozillaZine Knowledge Base

Why don't current versions work on Microsoft Windows98 or Microsoft WindowsME?

Firefox3, Thunderbird3, Sunbird0.3 share Gecko 1.9 for display layout. Gecko 1.9 uses the cairo open-source cross-platform graphics rendering library. With cairo, rendering text doesn't work on Windows98, WindowsME, WindowsNT.

(Reprieve: While Sunbird 0.3 used Gecko 1.9, Sunbird 0.5 and 0.7–0.9 use Gecko 1.8 for compatibility with Lighting 0.5 and 0.7–0.9 on Thunderbird 2.0, so Sunbird 0.5 and 0.7–0.9 can be used on Windows 98/ME/NT. Be aware of Windows timezone issues in release notes. When Thunderbird 3 comes out, Sunbird will use Gecko 1.9 again. Sunbird 0.9 and Lightning 0.9 are the last versions that will be compatible with Windows 98, Windows ME, or Windows NT. Sunbird and Lightning 1.0pre versions do not run on Windows 98, Windows ME, or Windows NT.)

OLD: may be able to build with GDI+ instead of cairo, but requires Microsoft's GDI+ dll. But as of 11 July 2006 Microsoft no longer supports Windows 98 and Windows ME, so Microsoft bugs are not going to be fixed.