MozillaZine

Talk:SSL is disabled

From MozillaZine Knowledge Base

(Difference between revisions)
Revision as of 13:35, 28 June 2007
AnotherGuest. (Talk | contribs)
(Screen shots should use default theme if possible)
<-- Previous diff
Revision as of 14:51, 28 June 2007
Np (Talk | contribs)
(Screen shots)
Next diff -->
Line 37: Line 37:
==Screen shots== ==Screen shots==
Small nit: Shouldn't screen shot use default theme?--[[User:AnotherGuest.|AnotherGuest.]] 13:35, 28 June 2007 (UTC) Small nit: Shouldn't screen shot use default theme?--[[User:AnotherGuest.|AnotherGuest.]] 13:35, 28 June 2007 (UTC)
 +:I think it's slightly preferable to use the defaults when making screenshots, but I don't think it matters that much. Feel free to create new screenshots.--[[User:Np|Np]] 14:51, 28 June 2007 (UTC)

Revision as of 14:51, 28 June 2007

I haven't tested any of these solutions, they're just stuff I pulled out of forum posts. I also don't know the menu path for the Options dialog for non-Windows non-Firefox users.--Np 20:21, 3 Aug 2005 (PDT)


Menu differences in Windows, Linux, and Mac http://kb.mozillazine.org/Menu_differences_in_Windows%2C_Linux%2C_and_Mac -- JamesMZ


I have added another method in solving this problem, and I solved my problem based on some of the info on the web and my limited knowledge to the problem.--IM 14:58, 15 NOV 2005 (EST)


SSL2 disabled gets a few support requests. As far as I know, there's no other entry that describes how to do this. This article is not a great place for the information, but I put it here for now as an expedient. Better here than nowhere. --AnotherGuest. 7 Dec 06

Contents

Split based on error message

I'm thinking we should split this article into sections based on whether the problem gives the "SSL is disabled" or the "Could not initialize" message. Doing so would reduce the number of things a user would have to check. Are each of these fixes geared towards a specific message, or can some apply to both? I'm going to try to test or find some forum links to see which problem results in which error:

"SSL is disabled"

  • Disabled SSL (tested)

"Could not initialize"

  • Corrupted or bad file permissions in profile (I made cert.db read only, and it happened at startup, and browsing SSL sites worked fine)

"SSL 2 is disabled"

  • SSL2 site (tested), [1]Image:Ssl2_disabled.png

Can't reproduce/find

  • OCSP (many different error messages, all with the text "OCSP" somewhere?)[2][3][4]
  • Manual proxy
  • Blocked loopback
  • Clear cache
  • Not compiled with SSL
  • After upgrade to 2.0.0.2 (gives security component message on startup and something on access) [5]

--Np 17:46, 11 June 2007 (UTC)

Asked in the forum [6]--Np 17:32, 26 June 2007 (UTC)

OCSP

Should we be telling everyone to turn off OCSP? From what I've read of bug reports, having OCSP enabled will only cause errors when you go to certain sites who have set up OCSP wrong, or if the OCSP service isn't working. I think we should say something along the lines of if they frequently get the error on a certain site, they can turn it off, but not suggest turning it off to solve other problems.--Np 18:11, 11 June 2007 (UTC)

Bug 110161 (ocspdefault) – enable OCSP by default fixed on trunk. They made it so that if the OCSP doesn't work, by default, the user isn't informed.--Np 06:27, 16 June 2007 (UTC)

Screen shots

Small nit: Shouldn't screen shot use default theme?--AnotherGuest. 13:35, 28 June 2007 (UTC)

I think it's slightly preferable to use the defaults when making screenshots, but I don't think it matters that much. Feel free to create new screenshots.--Np 14:51, 28 June 2007 (UTC)