MozillaZine

Import .pst files

From MozillaZine Knowledge Base

Revision as of 11:13, 14 February 2008; view current revision
←Older revision | Newer revision→
This article was written for Thunderbird but also applies to Mozilla Suite / SeaMonkey (though some menu sequences may differ).

Microsoft Outlook .pst files use a proprietary format. Thunderbird not only doesn't understand that format, it has no idea that .pst files even exist. Thats why there is no import command that lets you browse to the location of a .pst file.

Normally you import the contents of a .pst file by setting Outlook as the default email client, and then use Tools -> Import -> Mail within Thunderbird. Thats makes SimpleMAPI calls to Outlook, which returns the contents of the personal folders (.pst) file. See this article for information on how to import from more than identity. If some of the messages aren't imported correctly a common workaround is to import the messages into Outlook Express, and then import the messages from Outlook Express into Thunderbird.

If you are running Windows there are several mail conversion utilities that support importing .pst files. However, they actually make SimpleMAPI calls just like Thunderbird does. If you just have the .pst file (and can't install Outlook on the PC) you could:

  • Install Thunderbird on another PC that has a compatible version of Outlook.
  • Make Outlook the default email client.
  • Copy the .pst file to that PC and configure Outlook to use it.
  • Compact the .pst file using Outlooks File -> Data File Management commands to permanently get rid of any deleted messages. Don't confuse this with compressing or zipping a file.
  • Import the messages using Tools -> Import -> Mail. You can use Tools -> Import to also import the settings and address books.
  • Backup the Thunderbird profile. Mozbackup is a useful tool to do that.
  • Restore the Thunderbird profile on your PC.
  • Cleanup. (Uninstall Thunderbird on the PC with Outlook etc.)

What type/version of .pst file and what version of Outlook you are using matters. You normally can't open an Outlook 2003 .pst file (it defaults to Unicode) in Outlook 2002 (which only supports ANSI). You could export it as a Outlook 2002 compatible .pst file in Outlook 2003 using the File, New, Outlook Data File command, and then choose Outlook 97-2002 Personal Folders File (.pst) as the storage type.

If you are running Linux there are several open source utilities to convert .pst files to mbox files such as readpst , libpst and Outport . Thunderbird uses a separate mbox file for each folder to store all of the messages for that folder. None of those utilities seem to be under active development and they only support some of the versions of .pst files. You can use the ImportExporttools extension (it used to be called the mboximport extension) to import the mbox files.

The Thunderbird PST Import plugin lets you import selected folders from a .pst file under both Windows and Linux. Its based on readpst. Some of the dialog boxes are in French. [1] [2] Its not clear how well it works since nobody has reported using it in the forums and most of the comments on the download site reports it doesn't work. [3]

If you are running OSX Microsoft's web site has a tool to import .pst files into Entourage but it only supports .pst files from Outlook 2001 for the Mac, it is not compatible with any .pst files created by Outlook for Windows. Little Machines sells a product that can convert .pst files created by Outlook for Windows into files that can be imported into Entourage. This article explains how to import folders from Entourage into Thunderbird.

There is also Xena, a Java application that can convert several types of files (including .pst) into a XML archive format for long-term digital preservation . They provide a viewer, but its not clear if anything is available to convert the XML archive format into mbox files.

If none of these solutions solve your problem see this article for some generic advice on how to import and export messages. If you're switching to a new PC where you're going to run Thunderbird (instead of Outlook) its recommended you import your messages into Thunderbird before getting rid of (or cannibalizing) your old PC.

See also

External links