MozillaZine

Import .pst files

From MozillaZine Knowledge Base

(Difference between revisions)
Revision as of 04:01, 15 September 2010
Ahmad Alsayegh (Talk | contribs)
(OSX)
<-- Previous diff
Current revision
Tanstaafl (Talk | contribs)
(update office trial version links)
Line 1: Line 1:
{{Tbsuite}} {{Tbsuite}}
-Microsoft Outlook .pst files use a proprietary format. Thunderbird not only doesn't understand that format, it has no idea that .pst files even exist. Thats why there is no import command that lets you browse to the location of a .pst file.  
-'''Normally you import the contents of a .pst file by setting Outlook as the default email client, and then use Tools -> Import -> Mail within Thunderbird'''. Thats makes [[MAPI_Support | SimpleMAPI]] calls to Outlook, which returns the contents of the personal folders (.pst) file. See [[Import_from_Outlook_Express | this article]] for information on how to import from more than identity. If some of the messages aren't imported correctly a common workaround is to import the messages into Outlook Express, and then import the messages from Outlook Express into Thunderbird.+Importing from Outlook and Eudora in the built-in import wizard was disabled in version 38 as they broke. You can work around this by using an older version of Thunderbird.
 +[http://ftp.mozilla.org/pub/thunderbird/releases/17.0.9esr/win32/en-US/ Version 17.09] is probably your best bet as version 24.* and 31.* sometimes crash when importing. See [[Go back to an old version of Thunderbird]] for links to those setup programs.
-If you are running Windows there are several mail conversion [[Mail_Utilities | utilities]] that support importing .pst files. However, they actually make SimpleMAPI calls just like Thunderbird does. If you just have the .pst file (and can't install Outlook on the PC) you could:+[https://bugzilla.mozilla.org/show_bug.cgi?id=1175055 Bug report about disabling import]
 +[https://bugzilla.mozilla.org/show_bug.cgi?id=1176748 Bug report about actually fixing the problem]
 +Another solution would be to sign up for a free IMAP account (such as Gmail), add the account to both Outlook and Thunderbird, and then use the IMAP account as a intermediary to transfer your mail (without importing or forwarding it). This works because IMAP supports remote folders (on the mail server) that you can access just like they're local folders. Its sort of like copying a file between two PC's by copying it from the hard disk to a file share that both PC's use, and then copying it from the file share to the second PC's hard disk, except that you're copying messages. See [[Importing_and_exporting_your_mail#Migrating_messages_using_a_mail_server | Migrating messages using a mail server]] for more information.
 +
 +----
 +
 +
 +
 +'''Most import tools, and Thunderbird, require that a compatible version of Outlook be installed on the machine being used to import Microsoft outlook data. ''' Microsoft Outlook stores data in .pst files, which is a proprietary format. Thunderbird does not understand that format, nor does it know that .pst files even exist. So there is no Thunderbird import command that lets you browse to the location of a .pst file, nor can it import data if Outlook is not installed.
 +
 +'''Normally you import by setting Outlook as the default email client, and then use Tools -> Import -> Mail within Thunderbird'''. This method uses [[MAPI_Support | SimpleMAPI]] calls to Outlook, and Outlook accesses the contents of the personal folders (.pst) file. See [[Import_from_Outlook_Express]] for information on how to import from more than one identity. If some of the messages aren't imported correctly, a common workaround is to import the messages into Outlook Express, and then import the messages from Outlook Express into Thunderbird. If you're [[Move_to_a_new_PC | switching to a new PC]] where you're going to run Thunderbird (instead of Outlook) its recommended that you import your messages into Thunderbird before getting rid of (or cannibalizing) your old PC.
 +
 +Thunderbird is a 32-bit program, so it can't import from a 64-bit version of Outlook. Windows users can try [[Mail_Utilities | mail conversion utilities]], but they also make SimpleMAPI calls just like Thunderbird.
 +
 +''Alternatives'':
 +* If you just have the .pst file and can't install Outlook on the target PC you could:
:# Install Thunderbird on another PC that has a compatible version of Outlook. :# Install Thunderbird on another PC that has a compatible version of Outlook.
:# Make Outlook the default email client. :# Make Outlook the default email client.
Line 13: Line 28:
:# Import the messages using Tools -> Import -> Mail. You can use Tools -> Import to also import the settings and address books. :# Import the messages using Tools -> Import -> Mail. You can use Tools -> Import to also import the settings and address books.
:# Repeat steps 3-5 as necessary for any other .pst files. :# Repeat steps 3-5 as necessary for any other .pst files.
-:# [[Profile_backup | Backup]] the Thunderbird profile. [[MozBackup | Mozbackup]] is a useful tool to do that.+:# [[Profile_backup | Backup]] the Thunderbird profile. [[MozBackup | Mozbackup]] is a useful tool to do that.
:# Restore the Thunderbird profile on your PC. :# Restore the Thunderbird profile on your PC.
:# Cleanup. (Uninstall Thunderbird on the PC with Outlook etc.) :# Cleanup. (Uninstall Thunderbird on the PC with Outlook etc.)
-What type/version of .pst file and what version of Outlook you are using matters. You normally can't open an Outlook 2003 .pst file (it defaults to Unicode) in Outlook 2002 (which only supports ANSI). You could export it as a Outlook 2002 compatible .pst file in Outlook 2003 using the File, New, Outlook Data File command, and then choose Outlook 97-2002 Personal Folders File (.pst) as the storage type.+* If it is not practical to backup and restore a profile (perhaps one PC is using Windows and the other OSX) you could [[Moving your profile folder | move it]] instead.
-Outlook doesn't care what the folders names are since it stores all of the folders within a .pst file. Thunderbird however stores all of the messages for each folder in a file named after the folder, so if you use characters in a folder name that are invalid filename characters it can cause problems. If you get an error message about Thunderbird being unable to create a folder you may need to rename all folders to use 7-bit alphabetical ASCII characters and try again. Another possibility is that you had two child folders with the same name under two different parent folders. Rename one of the child folders. +* If you already created a new profile on your PC you could copy the [[Profile_folder_-_Thunderbird | profile]] from the other PC to it and then import its folders using either the [http://nic-nac-project.de/~kaosmos/mboximport-en.html ImportExportTools] add-on (recommended) or the [https://addons.mozilla.org/en-US/thunderbird/addon/90003/ Local Folders] add-on. That way you won't lose anything in your new profile.
-Thunderbird has no concept of Outlook identities or profiles so it only imports from the default identity or profile. If you have multiple identities or profiles you need to set one as the default, import it using Thunderbird, and then repeat. +* Consider signing up for a free IMAP account with Gmail, copying the messages to the inbox on the IMAP server (IMAP lets you copy/move messages to/from remote folders as if they were local fodlers), and then let Thunderbird download them.
 + 
 +* '''Use one of the operating specific solutions below. It includes a lot of solutions that don't work for most users, because it tries to be complete. You are usually better off installing one of the trial versions of Outlook and importing from it normally.'''
 + 
 +The type and version of .pst file, and version of Outlook you are using is important. You normally can't open an Outlook 2003 .pst file (it defaults to Unicode) in Outlook 2002 (which only supports ANSI). You could export it as a Outlook 2002 compatible .pst file in Outlook 2003 using the File, New, Outlook Data File command, and then choose Outlook 97-2002 Personal Folders File (.pst) as the storage type.
 + 
 +Folder names can also be tricky. Outlook doesn't care about mail folder names because it stores all of the folders within a single .pst file. Thunderbird however stores all of the messages for each folder in a file named after the folder. So characters in a folder name that are invalid filename characters for your operating system can cause problems when importing to Thunderbird. If you get an error message about Thunderbird being unable to create a folder you may need to rename all folders in Outlook to use 7-bit alphabetical ASCII characters and try again. Another possible problem is that you had two child folders with the same name under two different parent folders. Rename one of the child folders.
 + 
 +Thunderbird has no concept of Outlook identities or profiles, so it only imports from the default identity or profile. If you have multiple identities or profiles you need to set one as the default, import it using Thunderbird, and then repeat.
==Windows== ==Windows==
-A 60 day trial version of Outlook 2010 is available [http://office.microsoft.com/en-us/outlook/default.aspx here]. The simplest solution is to install it, configure it to use the .pst file and then import the messages into Thunderbird using Tools -> Import -> Mail. If some of the messages don't import cleanly see [[Import from Outlook Express| this article]].+Microsoft usually has some version of Outlook available as a trial version, that doesn't require a credit card (like [https://products.office.com/en-us/try try Office 365 for free] does). They periodically change the location and what version is available, so you might have to search for it. Currently its at [https://www.microsoft.com/en-us/evalcenter/evaluate-office-professional-plus-2013 Office evaluations]. The simplest solution is to install it, configure it to use the .pst file and then import the messages into Thunderbird using Tools -> Import -> Mail. If some of the messages don't import cleanly see [[Import from Outlook Express| this article]].
[http://pstwalker.com/pstwalker.html PSTWalker] is shareware that claims to be able to convert Outlook 97-2007 .pst files to MSG files, without using MAPI or requiring Outlook to be installed. The developers web site doesn't mention it, but [http://www.softlist.net/program/pst_walker-software.html this web site] claims it requires .NET Framework 2.0. You could use a conversion utility (such as this [http://bitdaddys.com/outlookEMLandMSGconverter.html?outlook-eml-and-msg-converter-reads-msg commercial software] or this [http://code.google.com/p/ruby-msg/ ruby based utility]) to convert the MSG files to either mbox or .eml files, and import them using the [http://pstwalker.com/pstwalker.html PSTWalker] is shareware that claims to be able to convert Outlook 97-2007 .pst files to MSG files, without using MAPI or requiring Outlook to be installed. The developers web site doesn't mention it, but [http://www.softlist.net/program/pst_walker-software.html this web site] claims it requires .NET Framework 2.0. You could use a conversion utility (such as this [http://bitdaddys.com/outlookEMLandMSGconverter.html?outlook-eml-and-msg-converter-reads-msg commercial software] or this [http://code.google.com/p/ruby-msg/ ruby based utility]) to convert the MSG files to either mbox or .eml files, and import them using the
Line 30: Line 53:
The [http://freshmeat.net/projects/pstimportplugin/?branch_id=72191&release_id=265973 Thunderbird PST Import plugin] is a open source utility to import selected folders from a .pst file under both Windows and Linux. Its based on readpst. Some of the dialog boxes are in French. [http://lifehacker.com/340521/import-outlook-pst-files-into-thunderbird-with-pst-import] [http://obm.aliasource.org/tools-pstimport.php] Its not clear how well it works since nobody has mentioned using it in the forums and most of the comments on the download site reports it doesn't work. [http://linux.softpedia.com/progViewOpinions/33014,.html] The [http://freshmeat.net/projects/pstimportplugin/?branch_id=72191&release_id=265973 Thunderbird PST Import plugin] is a open source utility to import selected folders from a .pst file under both Windows and Linux. Its based on readpst. Some of the dialog boxes are in French. [http://lifehacker.com/340521/import-outlook-pst-files-into-thunderbird-with-pst-import] [http://obm.aliasource.org/tools-pstimport.php] Its not clear how well it works since nobody has mentioned using it in the forums and most of the comments on the download site reports it doesn't work. [http://linux.softpedia.com/progViewOpinions/33014,.html]
 +
 +[http://www.littlemachines.com/index.html Outlook2Mac] is a inexpensive utility designed to "to move your Windows Outlook email, contacts, and calendar appointments from your PC to your Macintosh computer". It creates mbox files for the messages and vcf and/or vcard files for the contacts so that you could copy them to a Mac and import them into a email client that supports those standards. You could use the [http://www.nic-nac-project.de/~kaosmos/mboximport-en.html ImportExportTools] extension to import the mbox files and the [http://nic-nac-project.de/~kaosmos/morecols-en.html MoreFunctionsForAddressBook] extension to import the vcard or vcf files. It requires you to have a copy of Outlook installed - you can't use it if all you have is the .PST file.
 +
 +[http://mail.google.com/support/bin/answer.py?hl=en&answer=181235 Google Apps Migration for Microsoft Outlook] is a Google utility to upload mail, personal contacts, and calendar events from a .pst file to a Google Apps account. You could use those folders if you created a IMAP account for Google Apps in Thunderbird. The web page says you can use any Google Apps account though several blog posts claim its doesn't work with free (Standard Edition) Google Apps accounts. If you get a "This domain does not allow users to access the Email Migration API." error message that means you need to get the domain administrator to enable email migration for your domain, in order to upload.
==Linux== ==Linux==
-There are several open source utilities to convert .pst files to mbox files such as [http://kontact.kde.org/kmail/tools.php readpst] , [http://alioth.debian.org/projects/libpst/Libpst libpst] and [http://outport.sourceforge.net/ Outport] . Thunderbird uses a separate mbox file for each folder to store all of the messages for that folder. None of those utilities seem to be under active development and they only support some of the versions of .pst files. You can use the [http://nic-nac-project.de/~kaosmos/mboximport-en.html ImportExporttools] extension to import the mbox files.+There are several open source utilities to convert .pst files to mbox files such as [http://kontact.kde.org/kmail/tools.php readpst] , [http://alioth.debian.org/projects/libpst/Libpst libpst (alioth.debian version)] [http://www.five-ten-sg.com/libpst/ libpst (five-ten-sg version)], [http://sourceforge.net/projects/ol2mbox/ ol2mbox (yet another version of libpst)] and [http://outport.sourceforge.net/ Outport] . Thunderbird uses a separate mbox file for each folder to store all of the messages for that folder. None of those utilities seem to be under active development and they only support some of the versions of .pst files. You can use the [http://nic-nac-project.de/~kaosmos/mboximport-en.html ImportExporttools] extension to import the mbox files.
==OSX== ==OSX==
Line 41: Line 68:
The [http://www.entourage.mvps.org/import_export/pst.html Entourage Import PST files] help page has links to several products to import .PST files. It mentions [http://www.littlemachines.com/ Outlook2Mac], which can convert .pst files created by Outlook for Windows into files that can be imported into Thunderbird. However, it [http://www.littlemachines.com/o2m/help/faq.html#pst requires Outlook to be installed]. The [http://www.entourage.mvps.org/cross_platform/win_mac.html Convert Mail from Windows to Mac] has some other suggestions/links. The [http://www.entourage.mvps.org/import_export/pst.html Entourage Import PST files] help page has links to several products to import .PST files. It mentions [http://www.littlemachines.com/ Outlook2Mac], which can convert .pst files created by Outlook for Windows into files that can be imported into Thunderbird. However, it [http://www.littlemachines.com/o2m/help/faq.html#pst requires Outlook to be installed]. The [http://www.entourage.mvps.org/cross_platform/win_mac.html Convert Mail from Windows to Mac] has some other suggestions/links.
-Your best bet might be to buy the Personal Edition of [http://www.weirdkid.com/products/emailchemy/ Emailchemy]. Its not expensive and there is a demo version that "masks subject and sender fields in the converted email" that you could try first. Its user documentation states it supports "Outlook for Windows" but doesn't provide any details on what versions it supports. Their blog has an article about [http://www.weirdkid.com/blog/2008/09/28/using-emailchemy-on-corrupt-pst-files/ Using Emailchemy on corrupt PST files] which confirms they read the .PST file directly, not though any Microsoft API's or connectors.+If none of this help, you may need to buy a inexpensive commercial application that converts a .pst file to mbox files and the address books to .csv files. The [http://nic-nac-project.de/~kaosmos/mboximport-en.html ImportExportTools] add-on adds support for importing mbox files to Thunderbird. Thunderbird has built-in support using for importing .csv or .ldif files in Tools -> Import -> Address Books -> Text Files.
 +*[http://www.littlemachines.com/ LittleMachine's O2M] is a commercial application for migrating Outlook data from a Windows PC to a Mac. It converts the files to formats such as mbox files and .csv files that Thunderbird can use. files. Unfortunately, O2M requires you have to Outlook installed.
-There is another way to import .PST files to TB, but again you will need a Windows PC, first you will have to do the steps:+*[http://www.pstconverterpro.com/ PST Converter Pro] is a similar commercial application but it explicitly states it doesn't require Outlook and that it can convert the files directly on the Mac.
-([[Note]]'''Bold text''': you will need ([https://addons.mozilla.org/en-US/thunderbird/search/?q=localfolder&cat=all&lver=any&pid=1&sort=&pp=20&lup=&advanced= LocalFolder]) add-on in order to avoid losing any current profiles or emails in your MAC)+
-Credits for the first 7 points go to the writer at the top of this page+*The Personal Edition of [http://www.weirdkid.com/products/emailchemy/ Emailchemy] has a demo version that "masks subject and sender fields in the converted email" that you could try first. Its user documentation states it supports "Outlook for Windows" but doesn't provide any details on what versions it supports. Their blog has an article about [http://www.weirdkid.com/blog/2008/09/28/using-emailchemy-on-corrupt-pst-files/ Using Emailchemy on corrupt PST files] which confirms they read the .PST file directly, not though any Microsoft API's or connectors.
-1- Install Thunderbird on another PC that has a compatible version of Outlook.+==IMAP (works with any operating system)==
-2- Make Outlook the default email client.+ 
-3- Copy the outlook.pst file to that PC and configure Outlook to use it. (may need to be in the default location)+If none of these solutions solve your problem see [[Importing_and_exporting_your_mail#Migrating_messages_using_a_mail_server | Migrating messages using a mail server]] for advice on how to migrate messages using a free IMAP account as an intermediary. Don't confuse this with forwarding messages, a IMAP account lets you treat remote folders on the mail server as if they were local folders.
-4- Compact the .pst file using Outlooks File -> Data File Management commands to permanently get rid of any deleted messages. Don't confuse this with compressing or zipping a file.+
-5- Import the messages using Tools -> Import -> Mail. You can use Tools -> Import to also import the settings and address books.+
-6- Repeat steps 3-5 as necessary for any other .pst files.+
-7- Backup the Thunderbird profile. Mozbackup is a useful tool to do that. +
-8- Once you take the backup using Mozbackup, move the backup files to your MAC+
-9- As we all know, there is no MozBackup for MAC, but since the back up type taken by MozBackup is considered to be just a way of file compression, all you have to do is rename your back up file to "yourbackupname.[[ZIP]]" by clicking on command+i, unzip the back up file+
-10- By this point you should have installed LocalFolder add-on already, go to TB tools--> Account setting, and from the drop down menu choose "New Local folder", TB will ask you to name the new local folder and set the directory, so you will have to set the directory path to the unzipped backup file, exactly to ~/youunzippedbackup/Mail/Local folders+
-11- Now you wont see your inbox yet, so you will have to right click on the local folder you created earlier, Add a new folder and call it Inbox (DO NOT CHANGE THE NAME, otherwise you wont get your emails), and do the same of Drafts and Sent+
-12- By now you should have all your emails in the local folder, you are free now whether you want to move them to your main Local folder and delete the local folder you created, or keep them right where they are+
==Misc.== ==Misc.==
There is also [http://sourceforge.net/projects/xena/ Xena], a Java application that can convert several types of files (including .pst) into a XML archive format for long-term digital preservation . They provide a viewer, but its not clear if anything is available to convert the XML archive format into mbox files. There is also [http://sourceforge.net/projects/xena/ Xena], a Java application that can convert several types of files (including .pst) into a XML archive format for long-term digital preservation . They provide a viewer, but its not clear if anything is available to convert the XML archive format into mbox files.
- 
-If none of these solutions solve your problem see [[Importing_and_exporting_your_mail | this article]] for some generic advice on how to import and export messages. '''Using a free IMAP account as an intermediary works well'''. If you're switching to a new PC where you're going to run Thunderbird (instead of Outlook) its recommended you import your messages into Thunderbird before getting rid of (or cannibalizing) your old PC. 
If you have problems importing messages using mixed Western and Asian fonts see [http://forums.mozillazine.org/viewtopic.php?f=39&t=1954325] If you have problems importing messages using mixed Western and Asian fonts see [http://forums.mozillazine.org/viewtopic.php?f=39&t=1954325]
 +
 +If you get an error message that says Thunderbird can't write to the folder (while importing) check that the TEMP environmental variable points to a folder on your hard disk that has enough room to store a temporary copy of all of the messages.
==Contacts== ==Contacts==
Line 83: Line 101:
==External links== ==External links==
-* [http://www.aid4mail.com/ Aid4Mail] and [http://www.mailnavigator.com/reading_ms_outlook_pst_files.html PST Reader] are two examples of commercial programs that can messages from a .PST file as a mbox file. However, they require that Outlook be installed.+* [http://www.aid4mail.com/ Aid4Mail] and [http://www.mailnavigator.com/reading_ms_outlook_pst_files.html PST Reader] are commercial programs that can access messages in a .PST file and create an mbox file. However, they require that Outlook be installed.
* [http://blogs.msdn.com/b/interoperability/archive/2010/02/19/new-office-documentation-now-publicly-available.aspx Documentation on Office file formats] * [http://blogs.msdn.com/b/interoperability/archive/2010/02/19/new-office-documentation-now-publicly-available.aspx Documentation on Office file formats]
 +* [http://www.outlookpstviewer.com/ Outlook .PST Viewer] is a freeware tool to directly view the contents of a .PST file, without requiring Outlook to be installed. It also supports exporting attachments (but not messages).
* [http://support.microsoft.com/kb/296088 Oversized PST and OST crop tool] * [http://support.microsoft.com/kb/296088 Oversized PST and OST crop tool]
* [http://pstviewtool.codeplex.com/ PST Data Structure View Tool] * [http://pstviewtool.codeplex.com/ PST Data Structure View Tool]
Line 91: Line 110:
[[Category:Issues (Thunderbird)]] [[Category:Issues (Thunderbird)]]
[[Category:Migration (mail)]] [[Category:Migration (mail)]]
 +[[Category:OS X]]

Current revision

This article was written for Thunderbird but also applies to Mozilla Suite / SeaMonkey (though some menu sequences may differ).


Importing from Outlook and Eudora in the built-in import wizard was disabled in version 38 as they broke. You can work around this by using an older version of Thunderbird. Version 17.09 is probably your best bet as version 24.* and 31.* sometimes crash when importing. See Go back to an old version of Thunderbird for links to those setup programs.

Bug report about disabling import Bug report about actually fixing the problem

Another solution would be to sign up for a free IMAP account (such as Gmail), add the account to both Outlook and Thunderbird, and then use the IMAP account as a intermediary to transfer your mail (without importing or forwarding it). This works because IMAP supports remote folders (on the mail server) that you can access just like they're local folders. Its sort of like copying a file between two PC's by copying it from the hard disk to a file share that both PC's use, and then copying it from the file share to the second PC's hard disk, except that you're copying messages. See Migrating messages using a mail server for more information.



Most import tools, and Thunderbird, require that a compatible version of Outlook be installed on the machine being used to import Microsoft outlook data. Microsoft Outlook stores data in .pst files, which is a proprietary format. Thunderbird does not understand that format, nor does it know that .pst files even exist. So there is no Thunderbird import command that lets you browse to the location of a .pst file, nor can it import data if Outlook is not installed.

Normally you import by setting Outlook as the default email client, and then use Tools -> Import -> Mail within Thunderbird. This method uses SimpleMAPI calls to Outlook, and Outlook accesses the contents of the personal folders (.pst) file. See Import_from_Outlook_Express for information on how to import from more than one identity. If some of the messages aren't imported correctly, a common workaround is to import the messages into Outlook Express, and then import the messages from Outlook Express into Thunderbird. If you're switching to a new PC where you're going to run Thunderbird (instead of Outlook) its recommended that you import your messages into Thunderbird before getting rid of (or cannibalizing) your old PC.

Thunderbird is a 32-bit program, so it can't import from a 64-bit version of Outlook. Windows users can try mail conversion utilities, but they also make SimpleMAPI calls just like Thunderbird.

Alternatives:

  • If you just have the .pst file and can't install Outlook on the target PC you could:
  1. Install Thunderbird on another PC that has a compatible version of Outlook.
  2. Make Outlook the default email client.
  3. Copy the outlook.pst file to that PC and configure Outlook to use it. (may need to be in the default location)
  4. Compact the .pst file using Outlooks File -> Data File Management commands to permanently get rid of any deleted messages. Don't confuse this with compressing or zipping a file.
  5. Import the messages using Tools -> Import -> Mail. You can use Tools -> Import to also import the settings and address books.
  6. Repeat steps 3-5 as necessary for any other .pst files.
  7. Backup the Thunderbird profile. Mozbackup is a useful tool to do that.
  8. Restore the Thunderbird profile on your PC.
  9. Cleanup. (Uninstall Thunderbird on the PC with Outlook etc.)
  • If it is not practical to backup and restore a profile (perhaps one PC is using Windows and the other OSX) you could move it instead.
  • If you already created a new profile on your PC you could copy the profile from the other PC to it and then import its folders using either the ImportExportTools add-on (recommended) or the Local Folders add-on. That way you won't lose anything in your new profile.
  • Consider signing up for a free IMAP account with Gmail, copying the messages to the inbox on the IMAP server (IMAP lets you copy/move messages to/from remote folders as if they were local fodlers), and then let Thunderbird download them.
  • Use one of the operating specific solutions below. It includes a lot of solutions that don't work for most users, because it tries to be complete. You are usually better off installing one of the trial versions of Outlook and importing from it normally.

The type and version of .pst file, and version of Outlook you are using is important. You normally can't open an Outlook 2003 .pst file (it defaults to Unicode) in Outlook 2002 (which only supports ANSI). You could export it as a Outlook 2002 compatible .pst file in Outlook 2003 using the File, New, Outlook Data File command, and then choose Outlook 97-2002 Personal Folders File (.pst) as the storage type.

Folder names can also be tricky. Outlook doesn't care about mail folder names because it stores all of the folders within a single .pst file. Thunderbird however stores all of the messages for each folder in a file named after the folder. So characters in a folder name that are invalid filename characters for your operating system can cause problems when importing to Thunderbird. If you get an error message about Thunderbird being unable to create a folder you may need to rename all folders in Outlook to use 7-bit alphabetical ASCII characters and try again. Another possible problem is that you had two child folders with the same name under two different parent folders. Rename one of the child folders.

Thunderbird has no concept of Outlook identities or profiles, so it only imports from the default identity or profile. If you have multiple identities or profiles you need to set one as the default, import it using Thunderbird, and then repeat.

Contents

Windows

Microsoft usually has some version of Outlook available as a trial version, that doesn't require a credit card (like try Office 365 for free does). They periodically change the location and what version is available, so you might have to search for it. Currently its at Office evaluations. The simplest solution is to install it, configure it to use the .pst file and then import the messages into Thunderbird using Tools -> Import -> Mail. If some of the messages don't import cleanly see this article.

PSTWalker is shareware that claims to be able to convert Outlook 97-2007 .pst files to MSG files, without using MAPI or requiring Outlook to be installed. The developers web site doesn't mention it, but this web site claims it requires .NET Framework 2.0. You could use a conversion utility (such as this commercial software or this ruby based utility) to convert the MSG files to either mbox or .eml files, and import them using the ImportExportTools extension. Nobody has mentioned using PSTWalker in the forums and its not on any of the major shareware web sites.

The Thunderbird PST Import plugin is a open source utility to import selected folders from a .pst file under both Windows and Linux. Its based on readpst. Some of the dialog boxes are in French. [1] [2] Its not clear how well it works since nobody has mentioned using it in the forums and most of the comments on the download site reports it doesn't work. [3]

Outlook2Mac is a inexpensive utility designed to "to move your Windows Outlook email, contacts, and calendar appointments from your PC to your Macintosh computer". It creates mbox files for the messages and vcf and/or vcard files for the contacts so that you could copy them to a Mac and import them into a email client that supports those standards. You could use the ImportExportTools extension to import the mbox files and the MoreFunctionsForAddressBook extension to import the vcard or vcf files. It requires you to have a copy of Outlook installed - you can't use it if all you have is the .PST file.

Google Apps Migration for Microsoft Outlook is a Google utility to upload mail, personal contacts, and calendar events from a .pst file to a Google Apps account. You could use those folders if you created a IMAP account for Google Apps in Thunderbird. The web page says you can use any Google Apps account though several blog posts claim its doesn't work with free (Standard Edition) Google Apps accounts. If you get a "This domain does not allow users to access the Email Migration API." error message that means you need to get the domain administrator to enable email migration for your domain, in order to upload.

Linux

There are several open source utilities to convert .pst files to mbox files such as readpst , libpst (alioth.debian version) libpst (five-ten-sg version), ol2mbox (yet another version of libpst) and Outport . Thunderbird uses a separate mbox file for each folder to store all of the messages for that folder. None of those utilities seem to be under active development and they only support some of the versions of .pst files. You can use the ImportExporttools extension to import the mbox files.

OSX

See if Microsoft offers a trial download of Office for the Mac or Entourage on their web site. The exact product name will change. For example, at one time it was called Microsoft Office 2004 for Mac Test Drive 11.0. Currently its Office 2008 for Mac Trial Edition for the Mac. It includes Entourage.

Microsoft's web site has a PST Import Tool for Entourage "to import PST files from Microsoft Outlook 2001 for Mac". Unfortunately there doesn't appear to be a version that supports later .pst formats. This article explains how to import folders from Entourage into Thunderbird.

The Entourage Import PST files help page has links to several products to import .PST files. It mentions Outlook2Mac, which can convert .pst files created by Outlook for Windows into files that can be imported into Thunderbird. However, it requires Outlook to be installed. The Convert Mail from Windows to Mac has some other suggestions/links.

If none of this help, you may need to buy a inexpensive commercial application that converts a .pst file to mbox files and the address books to .csv files. The ImportExportTools add-on adds support for importing mbox files to Thunderbird. Thunderbird has built-in support using for importing .csv or .ldif files in Tools -> Import -> Address Books -> Text Files.

  • LittleMachine's O2M is a commercial application for migrating Outlook data from a Windows PC to a Mac. It converts the files to formats such as mbox files and .csv files that Thunderbird can use. files. Unfortunately, O2M requires you have to Outlook installed.
  • PST Converter Pro is a similar commercial application but it explicitly states it doesn't require Outlook and that it can convert the files directly on the Mac.
  • The Personal Edition of Emailchemy has a demo version that "masks subject and sender fields in the converted email" that you could try first. Its user documentation states it supports "Outlook for Windows" but doesn't provide any details on what versions it supports. Their blog has an article about Using Emailchemy on corrupt PST files which confirms they read the .PST file directly, not though any Microsoft API's or connectors.

IMAP (works with any operating system)

If none of these solutions solve your problem see Migrating messages using a mail server for advice on how to migrate messages using a free IMAP account as an intermediary. Don't confuse this with forwarding messages, a IMAP account lets you treat remote folders on the mail server as if they were local folders.

Misc.

There is also Xena, a Java application that can convert several types of files (including .pst) into a XML archive format for long-term digital preservation . They provide a viewer, but its not clear if anything is available to convert the XML archive format into mbox files.

If you have problems importing messages using mixed Western and Asian fonts see [4]

If you get an error message that says Thunderbird can't write to the folder (while importing) check that the TEMP environmental variable points to a folder on your hard disk that has enough room to store a temporary copy of all of the messages.

Contacts

If your Outlook contacts are in the Personal Address Book they're stored separately in a .pab file. If they're in the Outlook Address Book they're stored in the .pst file.

The easiest way to import contacts from a .pst file is to install the trial version of Outlook, export them as a .csv or .ldif file, and then import them using Tools -> Import -> Address Books -> Text Files. If you don't want to do that you could try exporting them as .vcf files using the trial version of Recovery Toolbox for Outlookand then import them using the MoreFunctionsForAddressBooks add-on.

See also

External links