MozillaZine

Import .pst files

From MozillaZine Knowledge Base

(Difference between revisions)
Revision as of 23:50, 12 November 2010
Tanstaafl (Talk | contribs)
(added OS X category)
<-- Previous diff
Revision as of 13:30, 22 January 2011
Wsm (Talk | contribs)
(wording changes only)
Next diff -->
Line 1: Line 1:
{{Tbsuite}} {{Tbsuite}}
-Microsoft Outlook .pst files use a proprietary format. Thunderbird not only doesn't understand that format, it has no idea that .pst files even exist. Thats why there is no import command that lets you browse to the location of a .pst file. +Microsoft Outlook stores data in .pst files, which is a proprietary format. Thunderbird does not understand that format, nor does it know that .pst files even exist. So there is no Thunderbird import command that lets you browse to the location of a .pst file - Thunderbird requires external tools to handle .pst files.
-'''Normally you import the contents of a .pst file by setting Outlook as the default email client, and then use Tools -> Import -> Mail within Thunderbird'''. Thats makes [[MAPI_Support | SimpleMAPI]] calls to Outlook, which returns the contents of the personal folders (.pst) file. See [[Import_from_Outlook_Express | this article]] for information on how to import from more than identity. If some of the messages aren't imported correctly a common workaround is to import the messages into Outlook Express, and then import the messages from Outlook Express into Thunderbird.+'''Normally you import by setting Outlook as the default email client, and then use Tools -> Import -> Mail within Thunderbird'''. This method uses [[MAPI_Support | SimpleMAPI]] calls to Outlook, and Outlook accesses the contents of the personal folders (.pst) file. See [[Import_from_Outlook_Express | this article]] for information on how to import from more than identity. If some of the messages aren't imported correctly, a common workaround is to import the messages into Outlook Express, and then import the messages from Outlook Express into Thunderbird.
-If you are running Windows there are several mail conversion [[Mail_Utilities | utilities]] that support importing .pst files. However, they actually make SimpleMAPI calls just like Thunderbird does. If you just have the .pst file (and can't install Outlook on the PC) you could:+Windows users can try [[Mail_Utilities | mail conversion utilities]], but they also make SimpleMAPI calls just like Thunderbird.
 + 
 +If you just have the .pst file and can't install Outlook on the target PC you could:
:# Install Thunderbird on another PC that has a compatible version of Outlook. :# Install Thunderbird on another PC that has a compatible version of Outlook.
Line 22: Line 24:
::* If you already created a new profile on your PC you could copy the [[Profile_folder_-_Thunderbird | profile]] from the other PC to it and then import its folders using either the [http://nic-nac-project.de/~kaosmos/mboximport-en.html ImportExportTools] add-on (recommended) or the [https://addons.mozilla.org/en-US/thunderbird/addon/90003/ Local Folders] add-on. That way you won't lose anything in your new profile. ::* If you already created a new profile on your PC you could copy the [[Profile_folder_-_Thunderbird | profile]] from the other PC to it and then import its folders using either the [http://nic-nac-project.de/~kaosmos/mboximport-en.html ImportExportTools] add-on (recommended) or the [https://addons.mozilla.org/en-US/thunderbird/addon/90003/ Local Folders] add-on. That way you won't lose anything in your new profile.
-What type/version of .pst file and what version of Outlook you are using matters. You normally can't open an Outlook 2003 .pst file (it defaults to Unicode) in Outlook 2002 (which only supports ANSI). You could export it as a Outlook 2002 compatible .pst file in Outlook 2003 using the File, New, Outlook Data File command, and then choose Outlook 97-2002 Personal Folders File (.pst) as the storage type.+The type and version of .pst file, and version of Outlook you are using is important. You normally can't open an Outlook 2003 .pst file (it defaults to Unicode) in Outlook 2002 (which only supports ANSI). You could export it as a Outlook 2002 compatible .pst file in Outlook 2003 using the File, New, Outlook Data File command, and then choose Outlook 97-2002 Personal Folders File (.pst) as the storage type.
-Outlook doesn't care what the folders names are since it stores all of the folders within a .pst file. Thunderbird however stores all of the messages for each folder in a file named after the folder, so if you use characters in a folder name that are invalid filename characters it can cause problems. If you get an error message about Thunderbird being unable to create a folder you may need to rename all folders to use 7-bit alphabetical ASCII characters and try again. Another possibility is that you had two child folders with the same name under two different parent folders. Rename one of the child folders. +Folder names can also be tricky. Outlook doesn't care about mail folder names because it stores all of the folders within a single .pst file. Thunderbird however stores all of the messages for each folder in a file named after the folder. So characters in a folder name that are invalid filename characters for your operating system can cause problems when importing to Thunderbird. If you get an error message about Thunderbird being unable to create a folder you may need to rename all folders in Outlook to use 7-bit alphabetical ASCII characters and try again. Another possible problem is that you had two child folders with the same name under two different parent folders. Rename one of the child folders.
-Thunderbird has no concept of Outlook identities or profiles so it only imports from the default identity or profile. If you have multiple identities or profiles you need to set one as the default, import it using Thunderbird, and then repeat. +Thunderbird has no concept of Outlook identities or profiles, so it only imports from the default identity or profile. If you have multiple identities or profiles you need to set one as the default, import it using Thunderbird, and then repeat.
==Windows== ==Windows==
Line 69: Line 71:
==External links== ==External links==
-* [http://www.aid4mail.com/ Aid4Mail] and [http://www.mailnavigator.com/reading_ms_outlook_pst_files.html PST Reader] are two examples of commercial programs that can messages from a .PST file as a mbox file. However, they require that Outlook be installed.+* [http://www.aid4mail.com/ Aid4Mail] and [http://www.mailnavigator.com/reading_ms_outlook_pst_files.html PST Reader] are commercial programs that can access messages in a .PST file and create an mbox file. However, they require that Outlook be installed.
* [http://blogs.msdn.com/b/interoperability/archive/2010/02/19/new-office-documentation-now-publicly-available.aspx Documentation on Office file formats] * [http://blogs.msdn.com/b/interoperability/archive/2010/02/19/new-office-documentation-now-publicly-available.aspx Documentation on Office file formats]
* [http://www.outlookpstviewer.com/ Outlook .PST Viewer] is a freeware tool to directly view the contents of a .PST file, without requiring Outlook to be installed. It also supports exporting attachments (but not messages). * [http://www.outlookpstviewer.com/ Outlook .PST Viewer] is a freeware tool to directly view the contents of a .PST file, without requiring Outlook to be installed. It also supports exporting attachments (but not messages).

Revision as of 13:30, 22 January 2011

This article was written for Thunderbird but also applies to Mozilla Suite / SeaMonkey (though some menu sequences may differ).

Microsoft Outlook stores data in .pst files, which is a proprietary format. Thunderbird does not understand that format, nor does it know that .pst files even exist. So there is no Thunderbird import command that lets you browse to the location of a .pst file - Thunderbird requires external tools to handle .pst files.

Normally you import by setting Outlook as the default email client, and then use Tools -> Import -> Mail within Thunderbird. This method uses SimpleMAPI calls to Outlook, and Outlook accesses the contents of the personal folders (.pst) file. See this article for information on how to import from more than identity. If some of the messages aren't imported correctly, a common workaround is to import the messages into Outlook Express, and then import the messages from Outlook Express into Thunderbird.

Windows users can try mail conversion utilities, but they also make SimpleMAPI calls just like Thunderbird.

If you just have the .pst file and can't install Outlook on the target PC you could:

  1. Install Thunderbird on another PC that has a compatible version of Outlook.
  2. Make Outlook the default email client.
  3. Copy the outlook.pst file to that PC and configure Outlook to use it. (may need to be in the default location)
  4. Compact the .pst file using Outlooks File -> Data File Management commands to permanently get rid of any deleted messages. Don't confuse this with compressing or zipping a file.
  5. Import the messages using Tools -> Import -> Mail. You can use Tools -> Import to also import the settings and address books.
  6. Repeat steps 3-5 as necessary for any other .pst files.
  7. Backup the Thunderbird profile. Mozbackup is a useful tool to do that.
  8. Restore the Thunderbird profile on your PC.
  9. Cleanup. (Uninstall Thunderbird on the PC with Outlook etc.)
Alternatives:
  • If it is not practical to backup and restore a profile (perhaps one PC is using Windows and the other OSX) you could move it instead.
  • If you already created a new profile on your PC you could copy the profile from the other PC to it and then import its folders using either the ImportExportTools add-on (recommended) or the Local Folders add-on. That way you won't lose anything in your new profile.

The type and version of .pst file, and version of Outlook you are using is important. You normally can't open an Outlook 2003 .pst file (it defaults to Unicode) in Outlook 2002 (which only supports ANSI). You could export it as a Outlook 2002 compatible .pst file in Outlook 2003 using the File, New, Outlook Data File command, and then choose Outlook 97-2002 Personal Folders File (.pst) as the storage type.

Folder names can also be tricky. Outlook doesn't care about mail folder names because it stores all of the folders within a single .pst file. Thunderbird however stores all of the messages for each folder in a file named after the folder. So characters in a folder name that are invalid filename characters for your operating system can cause problems when importing to Thunderbird. If you get an error message about Thunderbird being unable to create a folder you may need to rename all folders in Outlook to use 7-bit alphabetical ASCII characters and try again. Another possible problem is that you had two child folders with the same name under two different parent folders. Rename one of the child folders.

Thunderbird has no concept of Outlook identities or profiles, so it only imports from the default identity or profile. If you have multiple identities or profiles you need to set one as the default, import it using Thunderbird, and then repeat.

Contents

Windows

A 60 day trial version of Outlook 2010 is available here. The simplest solution is to install it, configure it to use the .pst file and then import the messages into Thunderbird using Tools -> Import -> Mail. If some of the messages don't import cleanly see this article.

PSTWalker is shareware that claims to be able to convert Outlook 97-2007 .pst files to MSG files, without using MAPI or requiring Outlook to be installed. The developers web site doesn't mention it, but this web site claims it requires .NET Framework 2.0. You could use a conversion utility (such as this commercial software or this ruby based utility) to convert the MSG files to either mbox or .eml files, and import them using the ImportExportTools extension. Nobody has mentioned using PSTWalker in the forums and its not on any of the major shareware web sites.

The Thunderbird PST Import plugin is a open source utility to import selected folders from a .pst file under both Windows and Linux. Its based on readpst. Some of the dialog boxes are in French. [1] [2] Its not clear how well it works since nobody has mentioned using it in the forums and most of the comments on the download site reports it doesn't work. [3]

Linux

There are several open source utilities to convert .pst files to mbox files such as readpst , libpst and Outport . Thunderbird uses a separate mbox file for each folder to store all of the messages for that folder. None of those utilities seem to be under active development and they only support some of the versions of .pst files. You can use the ImportExporttools extension to import the mbox files.

OSX

See if Microsoft offers a trial download of Office for the Mac or Entourage on their web site. The exact product name will change. For example, at one time it was called Microsoft Office 2004 for Mac Test Drive 11.0. Currently its Office 2008 for Mac Trial Edition for the Mac. It includes Entourage.

Microsoft's web site has a PST Import Tool for Entourage "to import PST files from Microsoft Outlook 2001 for Mac". Unfortunately there doesn't appear to be a version that supports later .pst formats. This article explains how to import folders from Entourage into Thunderbird.

The Entourage Import PST files help page has links to several products to import .PST files. It mentions Outlook2Mac, which can convert .pst files created by Outlook for Windows into files that can be imported into Thunderbird. However, it requires Outlook to be installed. The Convert Mail from Windows to Mac has some other suggestions/links.

Your best bet might be to buy the Personal Edition of Emailchemy. Its not expensive and there is a demo version that "masks subject and sender fields in the converted email" that you could try first. Its user documentation states it supports "Outlook for Windows" but doesn't provide any details on what versions it supports. Their blog has an article about Using Emailchemy on corrupt PST files which confirms they read the .PST file directly, not though any Microsoft API's or connectors.

Misc.

There is also Xena, a Java application that can convert several types of files (including .pst) into a XML archive format for long-term digital preservation . They provide a viewer, but its not clear if anything is available to convert the XML archive format into mbox files.

If none of these solutions solve your problem see this article for some generic advice on how to import and export messages. Using a free IMAP account as an intermediary works well. If you're switching to a new PC where you're going to run Thunderbird (instead of Outlook) its recommended you import your messages into Thunderbird before getting rid of (or cannibalizing) your old PC.

If you have problems importing messages using mixed Western and Asian fonts see [4]

Contacts

If your Outlook contacts are in the Personal Address Book they're stored separately in a .pab file. If they're in the Outlook Address Book they're stored in the .pst file.

The easiest way to import contacts from a .pst file is to install the trial version of Outlook, export them as a .csv or .ldif file, and then import them using Tools -> Import -> Address Books -> Text Files. If you don't want to do that you could try exporting them as .vcf files using the trial version of Recovery Toolbox for Outlookand then import them using the MoreFunctionsForAddressBooks add-on.

See also

External links