MozillaZine

Cannot send mail

From MozillaZine Knowledge Base

Revision as of 05:23, 13 March 2005; view current revision
←Older revision | Newer revision→

If you've followed instructions for configuring Thunderbird and still cannot send mail for one or more of accounts, the following may help:


Contents

Basic Troubleshooting

Firewalls and Antivirus

Verify that your firewall or your antivirus program is not blocking Thunderbird. If you recently upgraded Thunderbird, verify that the firewall is not blocking the new version.

Offline mode

Verify Thunderbird is in online, not in offline, mode: Click File > Offline; Work Offline should be unchecked. If you send a message while in offline mode, it goes to the Unsent Messages folder in Local Folders. See below for Advanced tips.

Outgoing mail settings

First, get the correct outgoing mail (SMTP) settings from your service provider, usually your Internet Service Provider (ISP): Try their website, search Google for your ISP plus the word smtp, or call them.

Verify the settings in Thunderbird exactly match what your ISP provides -- No typos (e.g. "smpt"), extra spaces, punctuation mistakes (e.g. no commas instead of periods) or capitalization errors (e.g. lowercase instead of Caps).

Click Tools > Account Settings > Outgoing Server (SMTP) (at the bottom of the left pane -- you may need to scroll down), and double-check:

  • Server Name
  • Use name and password: Your username might be your full email address (e.g. "johndoe@domain.com") or only the part before the "@" ("johndoe"), depending on your service provider. Also, try unchecking this box; your email service provider might not support it.
  • Use secure connection: Unless your service provider supports SSL connections for outgoing mail, select No.
  • Port: Some service providers use non-standard ports (25 is standard). If you're having problems, ask them which ports they support for SMTP or outgoing e-mail.
  • (For help with multiple servers, see Advanced tips, below.)

Also, click Tools > Account Settings > [account name] > Server Settings > Advanced > Smtp and verify the correct SMTP server is selected there. If you see "Relay access denied" or "Relaying denied" errors, be sure to verify this setting.

For Advanced Users

  • If you installed Thunderbird without offline support: Close Thunderbird and go to your profile folder. Backup the prefs.js file, then open it with a text editor (e.g. Notepad); delete only the line containing the "network.online" preference. (Be careful editing prefs.js; if you make a mistake -- you'll notice many settings changed -- close Thunderbird and restore the backup copy.)
  • Follow these instructions for logging and advanced troubleshooting. (The log will include your username, password and possibly other private information -- be sure to remove the private info if you send the log to anyone else.)

ISP's blocking port 25

In an effort to stop spam, many ISP's (Comcast, Cox, many others) block all traffic to port 25 on anything except their own SMTP servers. This plays out like this:

Say you configure your laptop's Thunderbird's "Outgoing Mail Server" to use smtp.mycompany.com port 25. When you test mail, it works, because you're not subject to Comcast rules on your company's network.

Now take the laptop home and try sending mail. Everything looks normal, no errors or anything. But that mail simply vanishes. Comcast drops it because it was addressed to port 25 and not to Comcast's SMTP server.

The fix is simple but may not work for all servers. In Thunderbird's "Outgoing Mail Server" panel, replace the default 25 with 587. RFC 2476 explains why this works for newer SMTP servers.

If this doesn't work, it may be possible to solve this with ssh tunnels and/or router changes. If you work out the details, please update this accordingly.

You can receive mail, but can't send it.

The symptoms are these: You carefully edit your outgoing eMail message, hit send and up comes a window asking for your username and password. (Hmmmm, you think, I already told Thunderbird about these...) You enter the desired info, tell Thunderbird to remember them and hit send again. After a pause of a few seconds, back comes that damned window. After several repitions of this, you cancel the send, and up comes an error window telling you that your SMTP server is down or some such.

A check of my system showed that sendmail was working just fine, and I could still send outgoing messages, just not with the convienence of Thunderbird.

The fix is to go to Edit -> Account Settings -> Outgoing server(SMTP) and turn off your name and password. You ISP's server does not require these, and it is confused when it gets them.

Hmmmmm - Mine says (sometimes): No sender was specified. Please fill in your email in the Mail & Newsgroups account settings. (like above, I've tried to fill in the stuff everywhere I could... something still NOT right -Netscape (ISP) IS NO HELP (THEY HAVE FARMED THERE HELP TO INDIA - I WRITE OF THIS; AND THEY WRITE ABOUT SOME THING TOTALLY NOT RELAVENT -So, here I am... HELP! SINKING FAST (MAY HAVE TO GO TO MSN -shudder- and they said they wouid walk me thru it)