MozillaZine

Cannot connect securely because the site uses an older insecure version of the SSL protocol

From MozillaZine Knowledge Base

(Difference between revisions)
Revision as of 01:59, 28 June 2007
Np (Talk | contribs)
(also enable ciphers)
<-- Previous diff
Revision as of 02:13, 28 June 2007
Np (Talk | contribs)
(link to summary article)
Next diff -->
Line 1: Line 1:
{{right-pic|Ssl2 disabled.png}} {{right-pic|Ssl2 disabled.png}}
-This article deals with the message "''Firefox cannot connect securely to (site name) because the site uses an older, insecure version of the SSL protocol''" when trying to go to certain sites. This message is shown because starting in Firefox 2, support for SSL 2, an older and insecure security protocol, was disabled by default.+This article deals with the message "''Firefox cannot connect securely to (site name) because the site uses an older, insecure version of the SSL protocol''" when trying to go to certain sites. For information on other messages received when accessing secure sites, see [[Error loading secure sites]].
-Mozilla recommends that sites do not use SSL 2. You should contact the webmaster of the site and tell them your problem. If you must access an SSL 2 site, you can re-enable SSL 2 in Firefox, though this isn't recommended.+The message is shown because starting in Firefox 2, support for SSL 2, an older and insecure security protocol, was disabled by default. Mozilla recommends that sites do not use SSL 2. You should contact the webmaster of the site and tell them your problem. If you must access an SSL 2 site, you can re-enable SSL 2 in Firefox, though this isn't recommended.
{{EditPrefBool|security.enable_ssl2|true}} {{EditPrefBool|security.enable_ssl2|true}}

Revision as of 02:13, 28 June 2007

Image:Ssl2 disabled.png

This article deals with the message "Firefox cannot connect securely to (site name) because the site uses an older, insecure version of the SSL protocol" when trying to go to certain sites. For information on other messages received when accessing secure sites, see Error loading secure sites.

The message is shown because starting in Firefox 2, support for SSL 2, an older and insecure security protocol, was disabled by default. Mozilla recommends that sites do not use SSL 2. You should contact the webmaster of the site and tell them your problem. If you must access an SSL 2 site, you can re-enable SSL 2 in Firefox, though this isn't recommended.

  1. Type about:config in the Location Bar.
  2. Press Enter.
  3. Find the preference name security.enable_ssl2.
  4. Double click on it to set it to true.

You may also need to enable specific ciphers. Still in about:config, enter ssl2 into the filter box and enable the ciphers presented.[1]