MozillaZine

Webmail extension stopped working

From MozillaZine Knowledge Base

This article was written for Thunderbird but also applies to Mozilla Suite / SeaMonkey (though some menu sequences may differ).

If the webmail extension stops working find out what changed. Its unlikely to stop working on its own unless the webmail page changed.

  • Use your browser to log into webmail and verify that web page is still available.
  • Check that you're still configured to work online. File -> Offline should list "Work Offline" in the list box.
  • Look in the dedicated thread for the webmail extension to see if other people have the same problem. Occasionally the hotmail and yahoo webmail layout changes, requiring an update to support the new web page. You could also go to the authors web site or where he uploads webmail extension files on Google groups (they're typically updated first) and see if you're running the latest version.
  • Otherwise its probably due to Thunderbird being unable to bind to the ports. This is usually due to your firewall or anti-virus program.

If you updated Thunderbird when it tries to check for new mail your firewall should recognize that you've replaced the executable and ask whether it should update its configuration to allow Thunderbird to access the Internet. However, some firewalls don't do this and silently block the connection (due to the old permissions). Delete your old firewall settings for Thunderbird, and add support for Thunderbird again. However, if you can send or receive using any account then the firewall is not the problem.

If you're using Yahoo webmail and its configured to use Yahoo classic, Yahoo might have issued an invitation to use the new Yahoo webmail. Login into Yahoo webmail using a browser, decline the invitation, and try again.

Recent changes to the Hotmail webmail page have made converting any attachments from Hotmails format to a POP stream much more CPU intensive and time consuming. If you get an error message such as "Could not connect to server localhost; the connection was refused." it might be timing out. Try increasing the connection timeout by changing Tools -> Options -> Advanced -> Network & Disk Space -> Connection -> Connection timeout from 60 to 180.

Try setting "View -> Message Body As -> Plain Text" and temporarily disabling your anti-virus program . Many anti-virus programs are configured to automatically update themselves and not every update is 100% compatible.

Select the Webmail extension in Tools -> Extensions , press the options button, and then enable logging. Try to figure out how far it got in the normal sequence before it ran into problems. That might help you figure out what it was reacting to. Make certain you disable logging afterwards, log files can grow extremely large.

Try running Windows in safe mode, especially if you're configured to automatically run windows update. If none of that helps, then ask for help in the dedicated thread.