MozillaZine

Transferring data to a new profile - Firefox

From MozillaZine Knowledge Base

This article explains how to selectively transfer Firefox user data and settings to a new Firefox profile and provides a list of suggested files. If you're using either Thunderbird or SeaMonkey, see Transferring data to a new profile - Thunderbird or Transferring data to a new profile - SeaMonkey.

Contents

Preparation

Back up your profiles

It's a good idea to first back up your profiles as a precaution. MozBackup (Windows only) and FEBE are popular ways to do this.

Create a new profile

Installing Firefox and running it for the first time automatically creates a "default" Firefox profile. Additional profiles can be created using the Firefox Profile Manager. If you haven't yet created a new profile, completely close Firefox by choosing File -> Exit (or Quit) and then open the Profile Manager and follow the prompts to create a new profile. Make note of the name you give to the new profile so you can distinguish between the old and the new. You can exit the Profile Manager at this point and a new profile folder will be created (if you don't open Firefox with the new profile, the newly created profile folder will be an "empty shell"). You can then copy the files containing the data you wish to transfer to the new profile folder. Firefox will create any additional files it needs when you actually start Firefox with the new profile.

Copy data to the new profile

Make sure that Firefox is completely closed before you copy data to the new profile.

It's recommended that you only copy data that would be a lot of work to recreate (such as bookmarks, passwords, and cookies) to the new profile. Extensions, themes, and preferences are a common cause of Firefox problems so you should re-install any extensions and themes and reconfigure your preference settings if you had problems with the old profile, instead of trying to transfer them. If you had problems with your old profile and haven't identified what set of files is causing your problem, it's recommended you copy files from your old profile folder to the new one in several steps, testing whether things are still working okay between steps.

If you were not having any problems with the old profile, you can delete the entire contents of the new profile folder and then copy everything you wish to transfer at once, into the new profile folder.

Firefox 4 and above

Transferring useful personal data to a new profile from an old profile that had problems:

  1. Open Firefox with your old profile, using the Firefox Profile Manager.
  2. In the Firefox Menu select "Help -> Troubleshooting Information" and click "Open Containing Folder" (see note below)
  3. When the profile folder window appears, close Firefox
  • Note: In Firefox 14 and later changed to "Show Folder" on Windows and "Show in Finder" on Mac OS and "Open Directory" on Linux. If you are unable to open Firefox using the old profile, you can navigate to the old profile manually. See Profile folder - Firefox#Finding the profile folder for details.

You will now be working within the Firefox profile folder window, which contains the files and folders that you are going to copy to your new profile. To make the transfer process easier, you should create a new "Transfer Profile" folder inside your old Firefox profile folder:

  1. Right click on a blank area of the profile folder window and create a New Folder.
  2. Rename this new folder to Transfer Folder.
  3. Copy into this Transfer Folder the following files and folders from your old profile and no others:

Files:

  • cert8.db
  • chromeappsstore.sqlite
  • content-prefs.sqlite
  • cookies.sqlite
  • formhistory.sqlite
  • key3.db
  • mimeTypes.rdf
  • permissions.sqlite
  • persdict.dat
  • places.sqlite
  • signons.sqlite
  • signons3.txt (if exists)
  • webappsstore.sqlite


Folders:

  • bookmarkbackups
  • chrome (if it exists)
  • searchplugins (if it exists)

Note: Any existing folders specifically relating to individual extensions that you may wish to re-install later may also be copied over (at your own risk)

Once you have completed the above, you are ready to copy the contents of the "Transfer Folder" into your new Firefox profile:

  1. Open Firefox using the Profile Manager and select the new profile you created earlier.
  2. In the Firefox Menu select "Help -> Troubleshooting Information" and click "Open Containing Folder". When the profile folder appears, close Firefox.
  3. Paste the Transfer Folder into the new profile folder and then copy/paste the contents of it into the new profile, overwriting the original files/folders in that profile. When complete, the Transfer Folder may be deleted or kept as a backup.
  4. Start Firefox using the new profile.

Firefox 3

Starting in Firefox 3, the file format has been changed for certain profile data. For example, Firefox 3 stores cookies in cookies.sqlite (instead of cookies.txt) and stores both bookmarks and browsing history in places.sqlite (instead of bookmarks.html and history.dat). When you open Firefox 3 with a profile that contains files from a previous Firefox version, Firefox 3 will "convert" the profile by using the information in the older files to create new files in the new format, but only if the profile does not already contain the Firefox 3 versions of those files. After the profile contents have been converted to the new format, older files may remain in the profile folder but they will no longer be used by Firefox 3.

Important: If you are copying data from a profile that was used in an older Firefox version to a new profile, make sure to delete the corresponding files in the new profile folder (e.g., delete the .sqlite files from a Firefox 3 profile) so that Firefox can create a file in the new format using the data in the copied file. In the case of bookmarks, you also need to delete (or rename) any bookmarks-(date).json files from the bookmarkbackups folder when you copy bookmarks.html to the profile and delete "places.sqlite"; otherwise, Firefox 3 will use a JSON backup to restore the missing bookmarks instead of converting the bookmarks.html file you copied.

Suggested profile contents to transfer

The following files and folders are found in your Firefox profile folder. Note that, on Windows 2000/XP/Vista and Linux, you will need to show hidden files and folders to navigate to the profile folder or search for the files.

Files

Bookmarks and browsing history:

  • bookmarks.html (Firefox 2) - Bookmarks
  • history.dat (Firefox 2) - Browsing history of previously visited websites
  • places.sqlite (Firefox 3) - Bookmarks and browsing history. Note that Firefox 3 stores both bookmarks and browsing history in the places.sqlite file.

You can alternately import a bookmarks HTML file if you wish to add those bookmarks to your current Firefox bookmarks. In Firefox 3, you can also use the Firefox Library "Restore" feature to replace your current bookmarks with a bookmark backup file (such as a dated JSON backup from the bookmarkbackups folder of another Firefox 3 profile) but this will not transfer your browsing history.

Cookies:

Download actions for file types:

Form history:

  • formhistory.dat (Firefox 2) or formhistory.sqlite (Firefox 3) - Saved entries for web forms and the Search Bar.

Passwords: (Both of these files must be copied)

Permissions:

  • hostperm.1 (Firefox 2) or permissions.sqlite (Firefox 3) - Per-site preferences for allowing cookies, images, popups, and extension install permissions.

Preferences:

  • user.js (an optional file) and prefs.js - User preference settings. Not recommended to transfer if you had problems in your old profile. You may need to manually edit the paths in prefs.js to reflect the new profile location. If the new profile doesn't have the same extensions, you may have some unused preferences set by those extensions, but that usually doesn't harm anything.

Security certificate settings:

  • cert8.db

Session storage:

Spelling corrections:

Site specific settings (e.g. Page Zoom):

  • content-prefs.sqlite (Firefox 3 only).

Folders

Note: You can import an HTML backup file into any Firefox version. You can restore a JSON backup in Firefox 3 by opening the Library window, selecting "Import and Backup - Restore -> Choose File", and choosing one of the bookmark backup files in this folder.

  • extensions - Contains added themes and extensions. Not recommended to transfer if you had problems in your old profile. After copying this folder or its contents to the new profile, delete the "extensions.ini", "extensions.cache" and "extensions.rdf" files from the profile folder. These files will be regenerated when you start Firefox. Note that some extensions store data in additional files in the profile, usually at the top of the directory. You'll need to move them separately.
  • searchplugins - Contains additional search engines, if you've added any to Firefox.

See also

External links