MozillaZine

Toolbar or windows layout not working

From MozillaZine Knowledge Base

This article was written for Thunderbird but also applies to Mozilla Suite / SeaMonkey (though some menu sequences may differ).
  • If the Mail or Message Pane toolbar doesn't seem to work correctly (for example, can't add or delete buttons):
  • Right click on the "broken" toolbar, select "customize", press the "Restore Default Set" button, and press the Done button. If you are using the CompactHeader add-on for the message pane (preview pane) you many need to either expand the headers or disable the add-on in order to customize that toolbar.
  • If that doesn't help select Help -> Troubleshooting Information. Depending upon what version you are running you will see either a "Open Containing Folder" or a "Show Folder" button. Press it. That will launch windows explorer (or whatever file manager your operating system uses). It will display the contents of your profile. Exit Thunderbird and delete xulstore.json . That stores the toolbar , window layout and size/position settings. Restart Thunderbird. That will create a new version of that file with default settings. If you don't have a xulstore.json file, delete localstore.rdf instead. Xulstore.json replaced localstore.rdf in one of the updates to version 38.
  • If every time you close the message pane it re-opens when you restart, xulstore.json is probably corrupt. Delete it per the instructions in the preceding paragraph.
  • If the menu bar is missing right click on the toolbar and select Menu Bar in the list box. If you are running Thunderbird 10 or later you could press either the ALT key or F10 and then select View -> Toolbars -> Menu bar instead.
  • If something is broken with the toolbar such as buttons go right to left on the menu bar, or you can't add a button right click on the toolbar, select customize, and click on the "Restore Default Set" button. Then drag and drop the buttons to customize the toolbar as desired, and click on the "Done" button.
  • If the Send button is missing when composing a new message something hid the "composition toolbar". Either press F10 or use View -> Toolbars -> Composition Toolbar to get it back. If it was replaced by a Send Later button check File -> Offline to see if you are working offline.
  • If you keep losing toolbar and message pane settings it might be due to CCleaner deleting files. If you use that utility configure it to leave Thunderbird's profile alone. Take a look at using BleachBit instead.
  • If you customized columns for a folder but that setting is forgotten when you restart select the folder in the folder pane, select properties, the general tab, and then press the "repair folder" button.
  • If Unified folders is not working correctly (perhaps you're missing some inbox folders) switch to View -> Folders -> All and verify that the folders are okay (i.e. do you have more than a problem with Unified folders). If they're okay exit Thunderbird and delete both the virtualfolders.dat file and the Smart Mailboxes directory in the profile. The directory might have a numeric suffix. It is the directory listed in the location field of the properties of the unified inbox folder. It does not contain any messages, all of its mbox files ("Inbox.", "Sent." etc.) are empty. Restart Thunderbird. It should re-create the file and directory with default values. If that doesn't help try deleting the panacea.dat file in the profile.
  • If something else in the windows layout is broken :
  • Try running in safe mode using "Help -> restart with add-ons disabled" to rule out it being a problem due to an add-on. You can also select safe mode by exiting Thunderbird and holding down the Shift key while double clicking the Thunderbird shortcut.
  • If the windows layout is okay but some of the window pane contents/controls is clipped (not visible) try pressing the "restore down" button (between the minimize and close buttons) to stop using full screen mode and then drag and drop a corner of the window/pane to resize it. If that doesn't work try moving part of the window off-screen so that there is more room to drag and drop the corner.
  • Select Help -> Troubleshooting Information. Depending upon what version you are running you will see either a "Open Containing Folder" or a "Show Folder" button. Press it. That will launch windows explorer (or whatever file manager your operating system uses). It will display the contents of your profile. Delete xulstore.json. That stores the toolbar, window layout and size/position settings. Restart Thunderbird. That will create a new version of that file with default settings. If you don't have a xulstore.json file, delete localstore.rdf instead. Xulstore.json replaced localstore.rdf in one of the updates to version 38.
  • If deleting xulstore.json doesn't help, try deleting xulstore.json, localstore-safe.rdf (special version of that file used in safe mode), directoryTree.json , foldertree.json (used by folder pane) , mailviews.dat (message views) , search.json, session.json (snapshot of the windows layout), and XUL.mfl (cached user data) instead. Linux uses xul.mfasl instead of xul.mfl, while OS X uses "XUL FastLoad File". You will lose any customizations stored in those files but Thunderbird will recreate those files as needed using default values when you restart it.
  • If you just updated Thunderbird and get gibberish near the bottom of the main window that is due to it unsuccessfully trying to find a copy of translated text. See Label="&blockImageCmd. label;.
  • If you are running some other software that resizes or modifies windows try disabling it. For example, one user used "Actual Windows Manager" to set the startup windows size for Thunderbird. However, that program mis-interpreted the tooltips as normal windows and resized them accordingly. [1]

If you are worried about deleting files in your profile, backup your profile first using either Mozbackup or one of the programs mentioned in this article

See also

External links