MozillaZine

Thunderbird 3.1 - New Features and Changes

From MozillaZine Knowledge Base

Thunderbird 5.0 has been released on June 28, 2011.

Thunderbird 3.1 was released on June 24, 2010 and is no longer supported as of April 24, 2012.

  • While the changes from 2.0 to 3.0 were substantial, Thunderbird 3.1 is a rather incremental release, but nevertheless has notable changes and improvements summarized here.
  • Everything in Thunderbird 3.0 - New Features and Changes should still be valid for Thunderbird 5.0 unless obsoleted in that article.
  • Changes after Thunderbird 5.0 which obsolete anything that's stated here should go into Thunderbird 6.0, etc.
  • Note that you have to use Lightning 1.0b2 or later with Thunderbird 3.1 as calendar extension.


Contents

New Migration Assistant

One of the most obvious changes is the migration from 2.0.0.x to 3.1, which is now more detailed and better coordinated with other activities [1]. Specifically, password requests and IMAP synchronization don't interfere any more with the setup questions during the migration process [2]. Rather than presenting all options on a single page in a tab like the old assistant [3], it is now organized in multiple pages and more like a dialog (as seen with other applications). However, you still want to read the options carefully to ensure that you get the setup you want, thus don't simply accept the defaults as they are presented.

Notes:

  • You can prevent the Migration Assistant from running by creating a boolean preference mail.ui.show.migration.on.upgrade set to "false" in the 2.0 profile before starting 3.1 for the first time.
  • The new Migration Assistant does no longer provide an option to choose between the "All Folders" and the "Smart Folders" views (now "Unified Folders"), it will retain your 2.0 settings. It is however easy to change that after migration using the arrow buttons on the right side of the folder-pane headings.
  • You can also run the Migration Assistant without an existing 2.0 (or earlier) profile. Start it with Help → Migration Assistant, then you can switch to the 2.0 default toolbar set, or install extensions to replace functionality no longer provided by the regular 3.1 installation.
  • You may want to restart Thunderbird after running the Migration Assistant, just to be sure that the selections "stick".

Welcome Page

The first page is presented after loading an old-version (2.0.0.x or earlier) profile in Thunderbird 3.1, and after any compatibility checks for extensions.

Migration Assistant TB 3.1, Page #1

IMAP Settings

If one or more of your accounts is IMAP, the following page appears:

Migration Assistant TB 3.1, Page #2 - IMAP only

The description in this page is not very specific what "synchronization" implies:

  1. If synchronized, and unless restricted by message age, the complete contents of a folder will be downloaded from the server and mirrored locally. Thus, it requires disk space to store these messages, and bandwidth to initially download them. After the initial download, only new messages need to be synchronized, which is done in the background, but without much control by the user. This may be a critical factor for users on metered or otherwise bandwidth-limited connections, who may want to forgo automatic synchronization.
  2. If you don't choose synchronization, messages will be downloaded from the server whenever you access them. There is however caching involved, i.e., if the message is in either disk or memory cache, it will be taken from there. Both caches are naturally much smaller than what the offline storage can offer.
  3. Other reasons to choose synchronization are message availability when no connection is present, and to allow message-body search and indexing by the new Gloda search system.

Keep Previous Settings

When entering this page, the default reflects the settings found in your 2.0 profile, e.g., "Do not Synchronize" is checked if you didn't flag any folders for offline use, and "Per Account Synchronization" if some but not all folders were set for offline use. If you do not want to make any changes, simply click on "Next" here and no existing account or folder setting will be changed [4], [5]. See the next section for making modifications to the synchronization status, where the "all" or "nothing" options override any prior per-account or per-folder selections.

Modify Offline Settings

A brief description of the available options:

  • With the first option, offline synchronization will be enabled for all folders and all accounts, thus consider carefully if you want to accept this choice. To support your decision, the estimated storage requirement is presented next to the synchronization option (label (a), after "Required:", which is based on your usage just before the migration, no connection to the server will be established yet at this time). The lower-right corner informs you about the current total disk-space usage of your IMAP folders (b) and how much space is left on the device where your profile is located (c). If you agree to synchronization, (b) increases by (a), and (c) decreases by (a) due to downloading those messages from the server.
  • The second choice is the best if you didn't use synchronization in the past and don't plan to use it now either. You can always activate synchronization later in the Account Settings or Folder Properties. The main side effect of not using local copies is that the new Gloda search function will not be able to search in message bodies, and you will have to manually activate server-side searches to get to the body-search option in the full Search Messages dialog. Also, messages won't be available when offline.
  • The third choice allows you to pick and choose for each account which individual folders are synchronized locally. You can also restrict synchronization for each account to a given most-recent time period. Select this option first and then click on the account name (d). This brings you into its Synchronization & Storage Account Settings (shown below), where you can click the "Advanced" button to get to the folder listing, or modify the time-restriction settings. Verify that the folder you want synchronized are checked, and those which you do not want to be copied locally are not checked. Close the dialogs to get back to the migration assistant.
Migration Assistant TB 3.1, Page #2 - Advanced

Toolbar Customizations

Like 3.0, the Migration Assistant proposes to use the header-pane buttons only and to reset the main toolbar to a minimum set [6]. If you made any customizations, and/or want to remove the header-pane action buttons later (see Message Header Pane below), you should go with the second option to retain your current toolbar (it should switch visibly as soon as you check the lower box):

Migration Assistant TB 3.1, Page #3

Note: If your icons are above the button text, upon restart they will revert to icons beside text. Just right-click to get the Customize palette the first time you open Thunderbird 3.1 later and change it to icons and text, it will stick this second time.

Features as Add-ons

Features present in the regular 2.0 and earlier releases had been removed in 3.0 and are now available as separately maintained extensions. The last two dialogs offer you to install the extensions for the compact (one-row) header pane [7], [8]; and the additional folder columns indicating size and number of messages in each folder [9], [10]. Click the Install button if you want these extensions:

Migration Assistant TB 3.1, Page #4
Migration Assistant TB 3.1, Page #5

Default Client

Image:Tb31defAppl.png

Once the Migration Assistant is done, click the "Close" button. Even if Thunderbird 2.0 was defined as your default application for mail, news, and/or feeds, you may be presented with a dialog confirming/re-establishing those settings. After that, you should be prompted for your account passwords unless you have them saved, and the "What's New" tab should be visible.

Global Database

The main feature which was introduced in 3.0 but for which no opt-out page shown in the Migration Assistant is the global database. It will be automatically activated after migration and starts indexing your messages. If you don't want to use the Gloda search (e.g., on a low-performance machine or just because you want to avoid the overhead), cancel all password requests and go into the Tools → Options → Advanced → General tab, uncheck "Enable Global Search and Indexer" there and then restart Thunderbird.

Server Security Settings

For both incoming and outgoing servers, the dialogs have been changed [11]. Specifically, the "Use name and password" and "Use secure authentication" checkboxes have been replaced by drop-down menus, and more specific options are provided.

Image:Tb31newAuth.png
  • Connection security:
    • None (the connection is not encrypted)
    • SSL/TLS (formerly SSL, the connection is encrypted)
    • STARTTLS (formerly TLS, the transmitted data is encrypted)
  • Authentication method:
    • No authentication (outgoing server only, no user name)
    • Normal password (password is not encrypted separately)
    • Encrypted password (transmit password after encryption)

Selecting "No authentication" corresponds to unchecking "Use name and password" in the old Outgoing Server (SMTP) settings. It is frequently requested when using a provider's server from within their network and usually doesn't require any connection security either. Authentication and encryption may still be required for the incoming IMAP or POP server.

The combination of "None" with "Normal password" should be avoided as your password would be transmitted in clear text over an unencrypted line. Note that the combination shown in the example is safe, STARTTLS will encrypt the password on the connection level. The Kerberos/GSSAPI and NTLM authentication methods are only of interest in an enterprise environment with centralized authentication.

Where authentication is required, the user name is usually either your full e-mail address, or just the part before the '@', depending on the instructions of your provider.

Message Header Pane

Image:Tb31hdrButtons.png

Customizable Header-Pane Buttons

The additional buttons in the header pane of a message are now a "real" toolbar and allow respective customization [12]. Right-click over the button area and click on "Customize", now you can drag-and-drop the buttons between pane and palette as you wish. You can also switch to icon-only mode (see image below) to save space. The userChrome.css entries to hide buttons as a workaround are now obsolete. However, if you don't need the toolbar in the header pane at all, the hints in Gaining Vertical Space are more efficient than removing the buttons one by one.

Last Address Cut Off

By default, Thunderbird 3.1 will fill up one header line ("to" or "cc") and then display the "more" button [13], [14]. The major improvement here is that the line is fully utilized again, whereas TB 3.0 showed just the first address and then the "more" already. Also, the number of remaining addresses is stated now to see how much is missing.

Note that the last address shown may be cut off by the "more" button, which was done on purpose so that the address appears to slide under the button [15]. Part of the address will be visible if at least 30px can be shown [16]. In releases before 3.1.7, the very last address of the list may not be fully visible without a "more" button present [17].

Customizing the "more" Button

A preference mailnews.headers.show_n_lines_before_more has been introduced in Thunderbird 3.1, but wasn't fully functional before 3.1.3 [18]. It allows to specify any number of n lines to be shown when opening a message before the "more" appears. The figure above shows an example for n=3 lines, where "more" now also indicates the number of additional addresses that will be shown once it is clicked on [19].

Showing 3 cc lines before "more" appears

For large n, using the preference may have a noticeable performance penalty. If your intention is to always show all addresses directly when opening the message, thus having selected an n of sufficient size, it may be more beneficial to disable the "more" mechanism entirely [20]. To do this, set the preference to zero (or any negative number). With this value, always all addresses of the headers will be displayed on opening of a message with minimum delay. Note that no vertical scrollbar will be displayed with this setting.

Gaining Vertical Space

Many 2.0 users complained about the new 3.0 header-pane design using up too much space. If you prefer the multi-row view over the single-row design of the Compact Header extension, there are still ways how to regain the approximate 2.0 spacing.

Even if you completely emptied the toolbar, it will nevertheless occupy vertical space. To gain it back, the entire toolbar and the "other actions" button can be hidden and the top padding removed with the following userChrome.css entries:

#header-view-toolbox, #otherActionsButton {
  display: none !important;
}

#expandedHeaderRows {
  padding-top: 0px !important;
}

The header-pane buttons in the multi-message view are not toolbars yet and thus not customizable. If desired, they can be hidden as follows:

#archive.msgHeaderView-button, #trash.msgHeaderView-button {
  display: none !important;
}

You can also reduce the space between headers (the default height per row is 1.5em), here by 16.7%:

.headerValue {
  line-height: 1.25em !important;
  padding: 0px !important;
}

Moving the Date Header

In Thunderbird 2.0 and earlier, the date and time of the message sent was part of the header block on the left-hand side, thus among all other heading. With 3.0, this was moved to the right underneath the toolbar buttons [21].

To list the date as part of the main headers again (especially when you removed the other items on the right side of the header pane), use the Config Editor to set/add mailnews.headers.extraExpandedHeaders to "date" (restart Thunderbird to see its effect), then you can remove the date header on the right-hand side with the following userChrome.css entry [22]:

#dateValueBox {
  display: none
}

Note that this will display the date after the standard from/subject/to/cc headers, you will have to use a binding to move it up within the headers [23]. Translation of the encoded date header to local time is retained.

Quick-Filter Bar

The Quick-Filter function has been substantially modified for TB3.1 and is no longer combined with the Gloda search bar [24]. Thus, if Gloda is enabled, you will have two search bars (the Gloda search as toolbar item, Quick-Filter search between the tab bar and the message/thread-list headings). The Quick-Filter bar is not customizable, but there is a "qfb-pivot" extension to add further search options and a feature to search by properties of the currently displayed message [25], [26].

This additional toolbar can be easily hidden if not needed. If the tab bar is visible, it has a search symbol at its right end which can be used to toggle the visibility of the Quick-Filter bar. Also, the keyboard shortcut Ctrl+F can be used to enable it, ESC to hide it (careful though, these shortcuts are shared with the Find in This Message function and alternatingly focus on either of those [27]). Note: The keyboard shortcut for the Quick-Filter Bar has been modified to Ctrl+Shift+K with Thunderbird 8.0 while Find in This Message retains the Ctrl+F keyboard shortcut.

Quick-filter bar, Windows XP default theme

While the old quick-search function had a drop-down menu with all possible selections, each search item can now be selected individually and combined to a more comprehensive search. Note that the Quick-Filter search remains independent from Gloda, thus also works if it is disabled. Message-body searches on IMAP folders are performed on the server, thus synchronization isn't required either.

The primary search terms Sender, Recipients, Subject, Body can be chosen as soon as you start using the Quick-Filter bar, and appear in the bar underneath. You can pick multiple criteria, in which case they are combined in an "or" logic (i.e., any of them has to match the search term to be listed as a result). Searches can now be restricted further by the buttons to the left of the bar. The "sticky" button allows to keep the filters applied when switching folders.

From left to right:

  • Show only unread messages
  • Show only starred messages
  • Show only messages from people in your address book
  • Show only messages with tags on them
  • Show only messages with attachments

The message list will now change color depending on the state of the search:

  • Clear: No Quick-Filter function is active, the full list is shown
  • Yellow: The Quick-Filter search is running, list may be incomplete
  • Blue: Searching is finished and the list can be accessed now
  • Red: The search didn't match any of the given criteria

For searching in unified folders, the reported status may be incorrect [28]. Click ESC or the close button to revert from the search results to the full message list.

Folder Pane

Image:Tb31folderPane.png

The "Smart Folders" have been renamed to "Unified Folders" [29], but their function of collecting the contents of same-type folders remains the same.

Note that the default has been reverted to "All Folders" for 3.1 [30]. Click the ◄► cycle arrows at the top of the folder pane until you see the heading of "Unified Folders".

When new mail arrives, the asterisk (spat) on the server and folder icons is back which was removed in 3.0, at least on Windows [31]. Also, the server and folder colors have been modified when indicating new mail. On Windows, the color corresponds to browser.anchor_color and can be set in the Config Editor [32], [33].

Archiving Messages

A hidden preference mail.server.default.archive_keep_folder_structure has been introduced which, if set to "true", retains the original folder/subfolder structure in the Archives folder rather than "flattening" it into the per-year or per-month structure [34].

Message/Thread List

It is now easier to add or remove columns from the message list of a folder. Thus far, you needed to find the little button with the drop-down menu in the upper-right corner of the list heading above the scrollbar. Now, right-clicking anywhere on the headings (Subject, Date, etc.) will open that menu and allows columns to be hidden (unchecked) or displayed (checked).

Now it is also possible to propagate a defined set of columns from one folder to another [35]. At the bottom of the column-picker menu, find the two new items "Reset columns to default" to revert any customizations, and "Apply columns to..." to copy the current selection to other folders.

Connection Notifications

Image:Tb31notify.png

Timeouts and other connection-related issues are no longer reported in a modal dialog, thus requiring to confirm with the "Ok" button, but in a slide-in message at the lower-right corner of the desktop similar to download-completed messages [36]. If you are using a line which is unreliable, that message may show up frequently. Also, the message won't wrap, thus may occupy a large portion of the screen above the task bar [37]. You can use the following userChrome.css definition to suppress this message:

#alertNotification {
  display: none !important;
}

Note that this may also affect other notification messages.