MozillaZine

Thunderbird 3.0 - New Features and Changes

From MozillaZine Knowledge Base

Thunderbird 5.0 has been released on June 28, 2011.

  • Thunderbird 3.0 was released on December 8, 2009 and is no longer supported.
  • Thunderbird 3.1 was released on June 24, 2010.
  • This article is still valid for both 3.1 and 5.0 unless obsoleted in those articles.
  • Changes after Thunderbird 5.0 which obsolete anything here should go into Thunderbird 6.0, etc.

A lot of changes in backend code and features have been performed since the release of Thunderbird 2.0 in April 2007. This article describes noticeable changes in Thunderbird 3.0 from the user's perspective, thus won't address all the technical details and bug fixes which were done behind the user interface. However, for those interested, links to relevant bug reports, wikipages, or forum threads are provided. Note that the individual KB articles yet have to be updated, which may take a while. If you are having problems after upgrading or with a new installation, look into Thunderbird 3.0 installation issues first for a more concise description.

Some but not all of these items also apply to SeaMonkey 2.0.

Notes:

  1. Unless explicitly stated, the contents of this article apply to all major platforms (Windows, Max OSX, Linux).
  2. All descriptions refer to the default theme, thus items may be missing or appear differently if you use another theme.
  3. Substantial redesign of theme items has been performed. A "classic" theme is available using the old icons.
  4. Many themes and extensions will not work (yet), thus verify that they have been updated for Thunderbird 3.0.
  5. Any userChrome.css entries you have defined for Thunderbird 2.0 may no longer work with the new version.

When updating from 2.0 or an older version:

  • A new migration assistant will show up, allowing you to customize the transition and to keep some of your old configurations.
  • All IMAP accounts will be marked for offline use, thus you will see increased network and disk activity after the first startup while synchronizing.
  • The main toolbar will be reset upon migration, removing all customizations and the message-specific buttons, in turn adding the Gloda search bar; it is possible to get your customizations back, but you will need to have done at least one customization from the right-click menu with the "old" toolbar.
  • If you have multiple accounts set up, the Smart Folders view will be the default. You can use the small ← and → buttons in the folder-pane headings to revert to the old per-account folders view.
  • The new Gloda search is switched on by default, thus upon migration, it will start indexing all your messages in all folders of all accounts; this can take considerable time and resources.


Contents

Message Viewer

The most obvious change becomes apparent when opening a message in Thunderbird 3.0, there has been a substantial redesign of the main toolbar [1] and the header pane of a message [2]. Also, tabs were introduced to allow easier browsing of multiple messages or folders within the same window [3]. These new features are close to finalized. There is also an extension proposed with variants of the header pane [4].

Selecting multiple messages now shows a summary in the message preview pane, rather than leaving it empty [5]. This allows to easier keep track of the messages selected, especially when there is substantial distance between them in the message list.

If you have three or more recipients in a message it will list two plus "more". Pressing "more" lists the remaining recipients in a scrollable pane [6]. The more button may not be visible if your mail window is too narrow [7], [8].

Note: The "brief" (compact) header view has been removed and only the "normal" or "all" (with View → Headers) views are available [9], [10]. An extension has been developed to reestablish the "brief" view and is based on the split-off code.

Action Buttons in Header Pane

  • The upper right corner of the header pane has buttons for frequently used actions added, which replicate the functions of the (by default now hidden) icons in the main toolbar.
  • There has been some extensive discussion on the usefulness of moving the message-specific buttons into the header area [11]. The header-button pane is defined as a regular toolbar [12], including an option to select between text+icon, text-only, or icon-only buttons [13].
  • Work is still pending to allow customization of the header-pane buttons to rearrange or hide specific buttons [14]. This is currently available as an extension only, and will hopefully be added for the next 3.1 release.
  • In turn, the respective toolbar buttons were removed from the default toolbar, but can be moved back into place manually using the "Customize" right-click menu [15]. During migration from an old profile, the migration assistant allows to copy the toolbar customizations; however, some settings may be lost upon restart and have to be reset again in the "Customize" menu, then they should stick [16].
  • To suppress the header-pane buttons, you can include the following code into your userChrome.css until toolbar customization becomes available:
.msgHeaderView-button {
  display: none !important;
}
  • Individual buttons can be addressed with .hdrReplyButton, .hdrForwardButton, .hdrJunkButton, .hdrArchiveButton, or .hdrTrashButton.
  • Header-pane appearance can be modified using #msgHeaderView, use .msgHeaderView-button for appearance of the buttons.
  • This will only affect the buttons when viewing an individual message. Add the following to also hide the buttons in the multi-message view:
#archive.multimessage, #trash.multimessage {
  display: none !important;
}

Address-Book Status for each Address

  • There is a star next to each shown e-mail, which is blank if the address is not yet present in the address book, and filled in yellow if it was found [17].
  • Similar to the bookmarking function in Firefox 3.0, click on it to add or modify an address-book entry for this address.

Avoiding "You" Replacement of Own Identities

  • By default, addresses in the From/To/Cc headings are now replaced with "You" if they match any of your identities [18].
  • This is ambiguous if you have multiple identities, even though hovering over the "You" entry will display the e-mail address in a tooltip. A bug report is pending to limit the use of "You" to cases where it is unambiguous, and there are also localization/etiquette issues [19].
  • As a workaround, go into the Advanced → Reading & Display preference tab and uncheck the "Show only display name for people in my address book" box, this will bypass the identity checking and always display name and address as it was actually sent in the message.
  • Where required by local grammar, localized versions may have separate "You" strings depending on whether the heading is in a "from" or "to" context [20].

Folder Pane

  • Folder names are now highlighted to indicate that they have new messages pending [21]. The color depends on the desktop theme [22], [23].
  • See the themes article for instructions on how to change that color.
  • Parts of the new "session restore" [24] functionality are now available [25] similarly to Firefox and SeaMonkey. The last folders are reopened on restart, though not without issues [26], [27]. This is not configurable [28] and may cause multiple uncoordinated password prompts [29], [30].
  • There is a modified version of the FolderPaneTools extension, which provides an option to select a default startup folder to be selected rather than the last folder before Thunderbird was closed [31].

Smart Folders

  • The advanced folder view has a new choice - smart folders [32]. That creates an inbox folder that merges the contents of all accounts' inboxes (includes POP, IMAP, and local folders), and has separate inbox folders for each account as child folders. This should not be confused with saved searches, which some users have gotten into the habit of calling smart folders. This view removes the inbox folder from its normal location.
  • Smart Folders will be the default view when migrating or adding a new account [33]. You can use the small ← and → buttons in the folder-pane headings to revert to the old per-account folders view.
  • Using smart folders or the conventional account view is also covered by the migration assistant when updating from 2.0 with an existing profile.
  • The topmost inbox (the one that is a global inbox for all accounts) has a Location field enabled in the folder listing. Unfortunately it currently just says "Inbox", which is useless information. You can enable the Account field, but it only lists POP accounts.
  • A Smart Folders section has been added to the Global Inbox article which has more information.

Message and Folder Tabs

  • Messages and folders can be opened in separate tabs now.
  • Right-click on a folder or a message in the thread pane and select "Open in New Tab" from the context menu.
  • Messages open in a tab by double-clicking by default [34], and tabs can be opened in the background without leaving the current tab [35]. The respective list of options is located in the Advanced preferences.
  • There are a couple of regressions in the tabbed view caused by the ongoing work on the new search functionality [36].
  • By default, the tab bar is also visible when just a single tab is present [37]. In the Config Editor, setting mail.tabs.autoHide to "true" hides the tab bar when only a single tab is present.
  • Note that after the redesign, the extended folder columns are no longer available. An extension is provided to add those back [38].

Display of Inline Attachments

  • When attachments are displayed inline, the file name is now included in the separator on top of the attachment, thus allowing a better identification [39].
  • Images which are larger than the width of the window can be automatically resized to fit the window width [40].
  • Watch for the zoom icon to show up in oversized windows, and click into the image to toggle between "fit to width" and "original size".
  • Alternatively set mail.enable_automatic_image_resizing (defaults to true).
  • Copying single images from a message (either attachments displayed inline or as part of the message body) to the clipboard is now supported [41].
  • While the context-menu item still reads "Copy Image Location", it will copy the image itself onto the clipboard in addition to the location. When pasting into an application, you may need to use "Paste As" to select the correct type (e.g., "Device Independent Bitmap" on Windows).

JavaScript

  • For security reasons, JavaScript is no longer supported for mail/news content [42], [43].
  • The javascript.allow.mailnews preference has been removed [44].

Disk Cache

  • Thunderbird 3.0 now comes with a disk cache, which can cache any remote content [45].
  • These are usually images referred to in HTML messages, or something trivial as the startup page, but also certificate data and even update files are cached.
  • Messages and their attachments are now cached on the disk for IMAP accounts as well [46].
  • This setting is in the Advanced preference pane, the default is 50MB. If you have privacy concerns, you should disable the disk cache (don't forget the IMAP offline copies as well). To do so, set its size to 0MB or the browser.cache.disk.enable pref to false.
  • While "about:cache" has been implemented, there is no easy access to the contents of the disk cache [47]. As a workaround, define the start page in Advanced → General as about:cache?device=disk, which allows you to examine the contents whenever the start page would be shown (e.g., entering a folder).

Cookies

  • For web content referred to by e-mail messages, news, or feeds, cookies are accepted and sent back to the server if requested [48].
  • By default, all cookies are accepted according to their expiration policy.
  • These settings are located in the Security → Web Content tab and similar to the respective Firefox pane [49].

News


Message Composition

A couple of new features have been introduced, causing a different behavior than what you may be used to from Thunderbird 2.0.

Quotes in Replies

  • In Thunderbird 3.0, the attribution line in the quotes includes now the date and time of the original message by default (mailnews.reply_header_type=2) [50].
  • If you highlight a specific portion (text and/or images) of a message before clicking on Reply, this portion only will be quoted, not the full message [51]. This also applies for the Options → Quote Message function while already in the composition window [52].
  • By default, any inline attachments displayed with a message will not be included in the quote even if View → Display Attachments Inline is checked. To revert to the old behavior of including such attachments, set the new mail.reply_quote_inline preference to "true" [53].

Forwarding and Message Attachments

  • Thunderbird 3.0 forwards inline by default now rather than sending messages as attachments [54], thus allowing easier editing of the messages and avoiding attachment-related problems for the recipients.
  • There are no longer squared brackets added to the "Fwd: original subject" subject, and the "Fwd" string can now be modified with the mail.forward_subject_prefix preference [55].
  • Holding the Shift key down when clicking Forward will now toggle between HTML and plain-text composition mode (i.e., the opposite of your default), thus making it consistent with the Write, Reply, and Reply All buttons [56].
  • If an account is set up with a signature, note that it is only added to your e-mail if the signature is enabled for forwarding messages in the Composition & Addressing panel [57]. If the signature is placed above the quote when replying, it will now also be placed before the original message rather than at the very end when forwarding inline [58].
  • If a message is forwarded as attachment, many servers reject message attachments these days based on an ".eml" suffix (file extension) to the attachment name. On the other hand, certain e-mail clients or operating systems rely on the suffix to identify them as such. Thus, there is now a checkbox for a new mail.forward_add_extension preference next to the forwarding mode in the Composition preference pane to toggle the presence of the file extension [59].

Send in Background

Note: This feature is partly implemented and has known bugs, but is usable for the average user. Read the material cited below, and use the feature with caution.

  • mailnews.sendInBackground preference set to True will send a message in the background, and under some circumstances provide automatic retries if a send failure occurs.
  • You may also want to set mailnews.show_send_progress to False.
  • Help is needed in bug 511079 to finish implementation. See this wiki article and this bug report for more detail.
  • Outbox article has a placeholder paragraph that needs updating when it's more functional [60].

Attachment Reminder

  • A warning message is now created if you have words in your e-mail (e.g., "attachment") indicating that something was supposed to be attached, but no attachment was actually added when you click "Send" [61].
  • If you haven't attached anything yet and type in a word matching the list, a notification bar shows up at the bottom of the composition window with an option to start the attachment dialog [62]. You can continue typing while that bar is shown.
  • In the Composition preferences, General tab, there is a checkbox to disable that feature. Use the "Keywords" button to modify the list of keywords which trigger the warning.
  • Quoted text in replies is skipped, to avoid that merely a reference to an attachment in the cited original message causes the warning.

Pasting of Images from the Clipboard

  • Thunderbird 2.0 allowed pasting of images into the message in lossy JPEG format only, where the low quality was a frequently criticized issue especially on Windows platforms [63].
  • While pasting in JPEG will remain an option, the default will be lossless PNG in Thunderbird 3.0.
  • Note that the format in which an image was put on the clipboard does not have an impact on how it will be pasted [64]. If you want to retain the original encoding of an image, you would have to save it first and then insert it into your message from a file [65]. Also, drag-and-drop from a file, a web page from your browser, or as attachment from another message will not recode the image.
  • There are certainly cases where you would prefer JPEG instead, e.g., if message size is more of an issue than image quality. Look at the description for the new clipboard.paste_image_type preference for the options [66]. Both PNG and JPEG are supported by the clipboard mechanisms of all major platforms, GIF is not available on Windows or Linux.
  • For JPEG, the encoding quality is determined by the operating system or hard-wired in Windows, thus not configurable [67]. The encoding quality on Windows has been increased from 50 (in Thunderbird 2.0) to now 92, along with better sampling parameters [68]. Note that the workaround of editing the Windows executable to modify the JPEG-encoding quality does no longer work in Thunderbird 3.0.
  • On Windows, copy-and-paste or drag-and-drop of images from a message viewed to another one currently composed is broken if the source is a local mail folder [69]. Double-click on the image in your composed message and change the location from mailbox:///C%7C/ to mailbox:///C|/ to correct the encoding error.

Content Disposition of Attachments

  • The default for the content disposition has been changed from inline to attachment, thus such attachments are no longer marked for display with the message but as "true" attachments, even if they are image or text which could be displayed with the message [70].
  • While this resolves some problems met with the previous default, it may not be your intention, thus set mail.content_disposition_type to 0 to revert to the old behavior.
  • Note that Gmail's webmail interface will not display forwarded message attachments with the new default content disposition correctly [71].
  • If you insert images (from menu, drag-and-drop, copy-and-paste) into an HTML message you compose, it will also get an "attachment" disposition by default [72]. This may cause issues with non-Mozilla e-mail clients or webmail systems.
  • Since just switching the default is not a satisfactory solution for all cases, this is subject to further investigation how the disposition can be determined from the attachment type or user interaction [73].

Encoding-Related Changes

  • When writing a message which contains characters not representable in the default encoding, a dialog box used to pop up asking whether to send in UTF-8 (Unicode) instead. This was considered confusing, especially for users not aware of the technical details.
  • Up-conversion to UTF-8 is now performed silently without asking the user [74]. It is possible to disable that up-conversion using encoding-specific mailnews.disable_fallback_to_utf8.* preferences [75]. Removing the dialog also resolves a couple of other issues, e.g., that dialog popping up during autosave of the message as draft.
  • Also removed was the potentially confusing dialog "Send as plain text or HTML?" if no other arrangements are made, e.g., in the address book. The new default behavior is to silently send as both plain text and HTML [76].


Message Archiving and Compacting

New "Archives" Folder

Image:Tb3archivesFolder.png
  • For each account, a folder can be specified to archive messages into with a single function [77], [78].
  • Note: Archving involves a move operation rather than a copy.
  • You can set the Archives folder location in the Copies & Folders pane of the Account Settings. For POP accounts using a Global Inbox, the Archives folder should be associated with the location of the Inbox [79].
  • The currently implemented scheme creates an Archives folder which contains subfolders for each year. In turn, those folders can contain per-month subfolders (see figure to the right). This is determined by a preference mail.server.default.archive_granularity (or mail.server.server#.archive_granularity for a specific account) with 0=single Archives folder, 1=by-year subfolders (default), and 2=year/month subfolders [80].
  • The granularity option is currently not accessible through any UI element [81].
  • The date sorted into represents the sending, not the archiving time.
  • In addition to the "archive" button of the header pane, one or more messages (as highlighted in the message/thread list) can be archived using Message → Archive from the menu or the 'A' keyboard shortcut. A bug is pending to prompt a warning message, which also may allow to reassign or disable the shortcut, to decrease the danger of accidentally archiving messages in this way [82], but nothing happend in time for the 3.0 release.
  • A toolbar button is now available for the archive function [83].
  • Archiving in Gmail IMAP accounts is a special case due to the "All Mail" folder/label [84].

Compacting Folders

  • Thus far, manual compacting was only possible through the menus. There is now a "Compact" button available to easier compact folders [85].
  • The functionality is the same as provided by the respective add-on available for TB 2.0 [86].
  • Right-click on the toolbar and select "Customize", then drag the "Compact" button to a location of your choice onto the main toolbar.
  • There is no keyboard shortcut for the compact function yet [87].


Searching

  • One of the most significant changes which finally landed is the new search interface [88], [89]. Search results are presented in a separate tab in a "faceted view" now.
  • The search tab provides for a timeline in addition to the detailed results, which gives you some idea when some peak of messages matching your search criteria arrived. Clicking on the time line narrows down your search to that period, and you can specify further criteria.
  • The backend uses a new indexing system (Gloda [90] = Global Database) is introduced, which allows better performance when trying to find messages [91], [92].
  • The search bar in the main toolbar has two roles, combining the old "Quick Search" with the new search interface:
    1. When using the default "Search Everywhere" search is performed using the indexing results, over all folders in all accounts. A list of possibly search terms and wildcard use doesn't seem to be available.
    2. The other filter functions apparently resemble the old "Quick Search" on the current folder. It is unclear at this time to which extent Gloda is actually used in this mode.
  • By default, Gloda indexing is enabled [93], also for migrating accounts. Note that indexing a large amount of e-mails takes considerable time and resources, especially when setting up a new account or migrating from an old profile!
  • For Gmail IMAP accounts, your messages are indexed in their primary folder as well as "All Mail" (and other folders for which a label was assigned).
  • The indexing can be enabled or disabled in the Advanced → General tab of the preferences. However, you may not get any (or obsolete) search results which are based on the Gloda database when indexing is disabled.
  • The Gloda Indexing can be disabled in the Advanced preferences. Note that this will only affect the extended capabilities for creating the search tab and the faceted view. If you don't need this feature and/or don't use search regularly, thus would prefer a better performance during normal use (i.e., no indexing in the background) over the indexed search, you can switch global indexing off. Neither the quick search options nor searching from the right-click context menu will be affected, those still work even with Gloda disabled, but may be slower than a Gloda-based search.
  • Integration of Thunderbird message folders so that they are searchable from the Vista Search function [94], similar work in progress for Spotlight Search in Mac OSX [95].


Address Book

  • The address book has been extended with a field for the birthday [96], other improvements are pending [97].
  • It is now possible to add a photo to each contact [98].
  • To whitelist addresses from Junk filtering, you can now select multiple address books [99].
  • For a recipient with more than one entries in the address book, currently only a single one will be offered from the auto-complete list [100].
  • On Mac OSX, searching the address book of the operating system is enabled by default [101], [102].


Account Management

Account Auto-Configuration

  • The account wizard can now determine (or guess) connection parameters from your e-mail address [103]. First stage is to compare your domain (i.e., the part of the e-mail address after the '@') against a list of known providers [104]. If there is no match, server names like imap.domain, pop3.domain, pop.domain, smtp.domain, mail.domain are generated and attempted to connect to. If successful, security protocols (STARTTLS, SSL/TLS, secure authentication) are probed to determine the connection settings.
  • Where both IMAP and POP access are available, auto-configuration uses IMAP if possible.
  • Note that startup with a new profile or using the "Add Account" button starts the old Account Wizard, which you may need to cancel first. Brief instructions:
    1. Use File → New → Mail Account or click on "Create a new account" under the "Accounts" heading of the startup page to proceed with the new auto-configuration.
    2. You have to enter a real name, the e-mail address (relevant to derive the connection parameters), and a password (used for probing and account verification, you can choose to have it stored in the password manager).
    3. Everything else should go automatic from there, you may see different settings being tested, finally the indicators for both incoming and outcoming servers should switch to a "green light" status (the selection menu for the outgoing server may be collapsed due to a known bug [105]).
    4. If it doesn't look right to you, click on "Edit" to make respective changes, then "Re-test configuration" to try again.
    5. Clicking "Create Account" at the end will verify the settings, it may still fail at that point if any of the parameters doesn't allow a proper login.
    6. If you run into problems, you can still go into the regular Account Manager using the advanced-settings link next to "Cancel" to correct any parameters.
  • This is not finalized yet with various bugs pending [106], [107]. The new account setup has replaced the old account wizard as default "Add Account" action [108].
  • The account wizard does not recreate a deleted account in the same account directory if you add the exact same account again. You used to be able to do this to retrieve your old mail messages if you made a mistake. [109]

Connection Settings

  • The "SSL" and "TLS" labels in the server settings have been renamed to more accurately reflect the algorithms used. While this is potentially confusing, no change in the underlying algorithms has been performed.
  • The new labels read "STARTTLS" (formerly "TLS") and "SSL/TLS" (formerly "SSL") [110]. Note that "STARTTLS, if available" is discouraged for security reasons [111] and no longer offered in the menu.
  • Make sure to select "STARTTLS" rather than "SSL/TLS" if the setup instructions require you to use "TLS" for the connection.
  • If there is a certificate error (domain mismatch, untrusted issue, expired, etc.), the same dialog used in Firefox 3.x shows now up and allows you to define an exception. Make sure that you really trust that certificate before excepting it to avoid intrusion.
  • There is now also a "Use secure authentication" checkbox available for SMTP settings.
  • Note: If an SMTP server does not support authentication (secure or not), you will now receive an error message and the e-mail is not sent [112]. Unchecking user name and password and/or secure authentication may resolve the problem. It is not recommended to use non-secure authentication without encryption.
  • While a server may allow either secure connection (SSL/TLS or STARTTLS) or secure authentication, a server may not support both methods at the same time [113]. Thus, uncheck the box if encryption is chosen and you run into problems.

IMAP Accounts

  • New IMAP accounts are set up with offline folders enabled by default now [114].
  • Existing IMAP folders are quietly marked for offline use [115]. Whether or not to change existing accounts to use offline synchronization is covered by the migration assistant when updating from an older version with an existing profile.
  • You can also fine-tune the synchronization policy manually as follows:
    • If you don't want to keep offline copies, disable that either in the Account Settings → Synchronization & Storage (renamed from Offline & Disk Space [116]) tab, or in the context menu of each folder in the Properties → Synchronization tab.
    • In the Advanced dialog of Message Synchronizing, you can select multiple folders with the mouse, or use the cursor keys (with Shift held down) to highlight a number of folders, then toggle their offline status with the Space bar all at once rather than individually.
    • Current synchronization policy is to download and keep all content in offline copies. You can use the per-server settings in the Synchronization & Storage tab (or mail.server.default.autosync_max_age_days to change the default for all servers) to limit the amount of messages downloaded from the server and retained offline based on their date to avoid keeping copies of old messages offline [117], [118], [119].
    • Bugs are pending to also restrict retention of those copies by space [120] and to limit the download bandwidth [121]. For Thunderbird 3.0, no disk-space limits can be specified and the full network bandwidth is utilized during synchronization.
    • You can restrict synchronization to messages viewed only (thus, not downloading preemptively) by setting mail.server.default.autosync_offline_stores or the server-specific variable to false [122], [123]. This will also avoid problems with ISPs blocking an account when exceeding a certain download-bandwidth threshold.
  • If you do not use synchronization, you may run into a problem when printing messages with attachments [124]. In this case, you will see a hanging "Preparing..." notification. As a workaround, cancel the dialog with the x in the title bar, then either select View → Message Source or open the attachment(s). After that, you should be able to print that message.
  • Note that Gmail maps messages to "labels" rather than the traditional folder concept. As a consequence, multiple copies of the same message may be held when offline storage is enabled (one for each label, e.g., "Inbox" and "All Mail"), thus increasing the disk space occupied [125].
  • According to this blog, Thunderbird 3.0 has built-in support for the IMAP Compress extension since beta 3 (an optional feature in the protocol, not an add-on). Fastmail.fm has been providing a compression proxy for their customers that does the same thing, and getting > 80% bandwidth savings on average. The bug report says it was only tested against a Cyrus IMAP server. That is what Fastmail.fm uses.

Signatures

  • Each identity can have a signature file associated with it as before. Alternatively, you can now create simple signatures also directly in the Account Manager [126].
  • For a plain-text signature, just enter the text into the area provided in the main Account Settings pane of that account, or in the Manage Identities dialog. You can use line breaks and special characters, including '&' or '<','>' in a plain-text signature.
  • What you enter as text is interpreted as an HTML signature if you check the "Use HTML" box. While you cannot use a direct formatting, any HTML markup (e.g., <b>bold</b>) can be entered. If you need a line break, an explicit "<br>" tag is necessary in HTML mode.
  • An enhancement request is pending to add HTML-edit capabilities [127], or it may be provided by an extension in the future.
  • When providing a signature file, the text box is disabled and any text you entered before retained but ignored. Instead, the content of the file is added as the signature.
  • The content type for the file provided is determined in the same way as for regular attachments. Specifically, Windows recognizes the type by the file extension. HTML files must end in ".htm" or ".html", files with any other extensions not associated with an image are interpreted as plain-text.
  • You can also add an image as the signature, which must be either of GIF, JPEG, or PNG formats to ensure that they can be displayed inline.
  • In the Composition & Addressing pane, there are now options to omit the signature when replying or forwarding [128], which is on for replies but off for forwarding messages. Note that the signature position above or below the quote in replies also affects its postition when forwarding now [129].

Message Aging

  • Note that the retention-policy setting applies to both the local offline store as well as the remote IMAP folder [130]. The labels have been clarified.
  • Equally, a retention setting for POP accounts applies to both downloaded messages and their corresponding copies left on the server.
  • The checkbox "Always delete read messages" is hidden by default now [131] and that feature is targeted to be removed for TB 3.1 [132]. Its scope is ambiguous and applies also when "Don't delete any messages" is selected. If using that feature is desired (or for verification of its settings), add the following to your userChrome.css file:
.keepUnreadOnly { display: -moz-box; }
  • The option formerly named "Use server defaults" actually means "my settings for the account in which the folder is located" and has been relabeled to "Use my account settings" [133].
  • Restrictions to download size still don't work correctly, settings of "Don't download messages larger than" may be incorrectly reloaded when revisiting the Disk Space / Synchronization & Storage page and swapped between accounts [134].
  • For newsgroups, the option "Remove bodies from messages more than a number of days old" may not be functional [135].
  • If you are using a POP account with a Global Inbox, the retention policy of the account applies in which the Inbox is located, not the account referring to the Global Inbox.

Activity Manager

  • When selecting Tools → Activity Manager, a new window appears providing a list of ongoing and completed activities with respective time stamps [136].
  • In analogy to the error console, it allows you to monitor in more detail what's going on in the system and which activities are currently performed (e.g., syncing of IMAP offline folders, download of new POP messages).
  • The messages are yet a bit unspecific and may change.


Preference Settings

There are efforts ongoing to clean up the preference panes [137], [138]. Thus far, not much of this has actually been implemented [139]. Some options have been added, others removed, and some moved into different panes of the Options dialog.

Moved Preferences

  • The check for default e-mail client now moved to the Advanced pane.
  • Various settings of the General tab in the Advanced pane moved into a new Advanced → Display tab.

Add-On Manager

  • Similar to Firefox 3.0, the add-on manager can be accessed through the General tab in the preferences.

Removed Preferences

These depreciated or not frequently used preferences were removed from the Options, but are still available as "hidden" preferences through the Config Editor.

Display settings, Fonts dialog:

  • "Apply default character encoding..." mailnews.force_charset_override (defaults to false).

Composition settings:

  • "For messages that contain 8-bit..." mail.strictly_mime (defaults to false).
  • "Wrap plain text messages at..." mailnews.wraplength (defaults to 72).

Advanced settings:

  • "Remember the last selected message" mailnews.remember_selected_message (defaults to true).
  • "Connection timeout" mailnews.tcptimeout (new default 100, affects all protocols: IMAP/POP3/NNTP/SMTP).


API

This mail message mentions that Shredder has a new feature that allows custom filter actions to be added through extensions. FiltaQuilla and ToneQuilla at http://mesquilla.com are two examples of this.

An overview of the Thunderbird interface is available here. It is currently a draft.

Information about the Gloda global data base is available at

This blog entry and several mail messages on org.mozilla.lists.dev-extensions [140], [141], [142] mention that Shredder adds the ability for JavaScript code in an extension to make Java calls as long as a 32-bit JRE is installed. You need to include the JavaScript from a chrome: URL for it to have the needed permissions.


Application.ini

The installation directory has an application.ini file with general information about the build you are using and additional entries that control whether the profile manager and extension manager are enabled. There don't appear to be corresponding settings in prefs.js.

Build ID and Source References

The first block in application.ini identifies the program version and build used. A new entry now also provides a reference to the Mercurial repository [143], which is of use for users of nightly and tinderbox builds (e.g., to verify whether or not a specific patch has landed in that build).

BuildID=20090523031650
SourceRepository=http://hg.mozilla.org/comm-central
SourceStamp=1a25ea0c8358

would indicate that the sources for this May 23, 2009 build can be accessed at http://hg.mozilla.org/comm-central/file/1a25ea0c8358 (there is no corresponding entry for the mozilla-1.9.1 repository).

Crash Reporter

If you use the Crash Report Helper add-on (it requires Shredder) crashreporthelper.thisapphasquit is used to remember how Shredder exited and will be false (user set, rather than default) in about: config and true in prefs.js if it exited normally according to the author. There is nothing wrong with this, its mentioned only because most users expect that if an add-on creates some add-on specific settings they will have default values unless the user changed something.

It adds settings in application.ini to enable/disable itself, and to specify where to submit reports. It sets ServerURL=https://crash-reports.mozilla.com/submit. That URL is not mentioned in the Breakpad article and doesn't appear to be in any of the .js files in the default directory.


Migration Assistant

Upon starting up the first time, if an older Thunderbird profile is found, a tab appears with the following options [144]:

  • Synchronization of IMAP folders, keeping local copies for offline use (can be chosen globally or on a per-account basis).
  • Reset the main toolbar, thus removing all message-specific buttons, or retain the old toolbar with all customizations (it will be switched to text beside icons in either way).
  • Switch the folder view to Smart Folders or retain the per-account All Folders view.

Note that the migration assistant can be opened at any time from the Help menu.


Reverting to Thunderbird 2.0

Thunderbird 3.0 didn't change how Thunderbird stores mail messages or address books. While it is not recommended, you can use the same profile with both Thunderbird 2.0.0.x and the latest nightly build for Shredder, and switch back and forth between versions. The main impact is that not all add-ons work with both versions (despite changing some settings per Updating add-ons) and that your cookies and passwords are stored in different files in Shredder, so if you reverted you'd use the (old) Thunderbird 2 versions of those files. Thunderbird 3.0 uses Gecko 1.9.1 while Thunderbird 2.0 is based on Gecko 1.8.1, which in general appears to be transparent to the user.

The Thunderbird 3 Planning document proposes a number of significant changes such as roaming support, changing how accounts are added, using MozStorage for address books, eliminating RDF files, and bundling Lightning into the installer. So far, it is unclear to which extent architectural changes will be included in a future 3.x release, and which effect those would have on the compatibility between 2.0 and 3.x profiles.

Note: There has been a report that 3.0 may grab the default e-mail client association from 2.0 on Mac OSX despite canceling the respective dialog, thus invoking 3.0 instead of the 2.0 release version when opening links from a browser.

MozStorage

If the backend is switched to using MozStorage (SQLite) instead of Mork for the message summary database, that shouldn't cause a problem since Thunderbird 2 will automatically rebuild the *.msf files if they're missing. Switching to MozStorage for the address books would cause a problem, but you could export your address books as .ldif or .csv files. In comparison, Firefox 3.x enables journaling, but doesn't provide a way to use it to recover data from damaged SQLite files. That's why there are JSON backups of the bookmarks, but there is no similar backup for the history. If Shredder/Thunderbird used SQLite for address books you'd probably run the same type of risk.

Saved Passwords

The passwords are stored at a new location now. Thus, when going forth and back between 2.0 and 3.0 versions, your password lists do not get updated.

Main Toolbar

Note that Thunderbird 2.0 uses mail-bar2 in localstore.rdf for customizations, whereas 3.0 now uses mail-bar3. Consequently, customizations done for 2.0 will not affect those in 3.0 if a profile is shared.


Lightning

"There isn't a stable Lightning release for Thunderbird 3 test builds" [145]. In the interim use a Lightning nightly trunk test build. "The current plan is to work with the Lightning Add-on community to make a version of it available as an add-on to Thunderbird 3 after we ship later this year. This is a change from our initial plan of integrating all of Lightning into Thunderbird by default."[146], [147]

Lightning is expecting the 1.0 beta 1 release shortly, which will be compatible with Thunderbird 3.0 [148]. For the time being, you can use the nightly builds [149], which may be unstable though.


System Requirements

The system requirements match those of Firefox 3.5 now. This means that Windows versions earlier than Windows 2000 are no longer supported, and Mac OSX 10.4 is needed as a minimum. For Linux, most non-enterprise versions for which the distributor provides current patches should work, e.g., Gtk 2.10 and other more recent libraries are required.

There is a known issue running 32-bit builds on 64-bit Debian or Ubuntu distributions (and their variants), where a library issue prevents network connections [150], [151]. The workaround is to set network.dns.disableIPv6 to "true" or to install the correct version of the lib32nss-mdns package.


See also


External links