MozillaZine

Moving your profile folder

From MozillaZine Knowledge Base

This article describes how to move a profile for your Mozilla application, if you want to do the following:

  • Change the location where your profile is stored.
  • Move your profile from one computer to another when it's not practical to back up your profile, copy the backed up files to the other computer and then restore the backup using software like MozBackup that knows how to update the profiles.ini file.
  • Manually restore a profile backup to a different location.
  • Manually restore a profile backup after reformatting the hard disk.
  • Configure another operating system account to use the same profile. In this case you don't physically copy the profile since you're just updating another user's profiles.ini file to use the same profile. However, you may find it easier to share a profile if you move it first to a location whose path doesn't depend upon the user name.

If you're migrating from Windows to Linux, you may find Moving from Windows to Linux more useful. If you're using Thunderbird, you may find Moving your profile folder - Thunderbird easier to follow, since it doesn't cover multiple applications as this article does.

Note on moving profiles between operating systems: If you move your profile between dissimilar operating systems (Windows to Mac OS X for example) the path names in the prefs.js file (your settings) may have the wrong syntax. Thunderbird and Mozilla Suite/SeaMonkey, for example, use the same format to store messages and address books on all platforms. In such cases, you can update the information stored in the prefs.js file by using the "Browse" button for the local directory in your Options/Preferences for (Mail & Newsgroups) Account Settings -> Server Settings and (Mail & Newsgroups) -> Account Settings -> Local Folders to specify the correct account and mail directories.

Contents

Background

Mozilla applications don't know how to discover a profile by just looking in the default location where profiles are stored. They look in the profiles.ini file (Firefox, Thunderbird, and SeaMonkey 2) or in the "registry.dat" file (Mozilla Suite/SeaMonkey 1.x) to find what profiles exist and where they are located. When you create, rename, or delete a profile using the Profile Manager, the information stored in this file is updated. While it's possible to move a profile somewhere and then manually update the profiles.ini file, that is not recommended as it's error-prone.

Note: Portable Firefox and Portable Thunderbird don't support a profiles.ini file or a Profile Manager, since the profile is stored in a portable drive that is moved between computers. See this article for how to move your Firefox profile to Portable Firefox. See this article for how to to move your Thunderbird profile to Portable Thunderbird.

Don't proceed until you have found the profile folder that you want to "move". If you haven't done this before, it's recommended that you make a backup of all of your profiles before continuing.

Using the Profile Manager to move your profile

Firefox Thunderbird and SeaMonkey 2

Image:Profilemanager1.png
  1. Completely close your Mozilla application
  2. Copy the profile folder to the location where you want to store it. (You can copy it anywhere, except the application's program directory.) Skip this step if you're just trying to share a profile with another user.
  3. Start the Profile Manager. A window similar to the one shown will open.
  4. Click on the "Create Profile..." button.
    • In SeaMonkey 2, first click on "Manage Profiles...", then click on "Create Profile...".
  5. In the dialog that opens, enter a descriptive name for the profile.
  6. Click on the "Choose Folder..." button. A "Browse for Folder" dialog will open.
  7. Select the profile folder you copied and click OK.
  8. Review the path shown in the "Completing the Create Profile Wizard" dialog to make sure it is correct, then click "Finish" to create the new profile.
  9. Select the new profile and press the Start button to start Firefox or Thunderbird using the moved profile.
  10. If you're using Thunderbird, check that you can see the folders for each account. If they're missing, use the "Browse" button for the local directory in Tools -> Account Settings -> Server Settings and Tools -> Account Settings -> Local Folders to specify the correct account and mail directories.

Mozilla Suite and SeaMonkey 1.x

Note: If you are moving a profile with the same name as an existing profile (for example, the "default" profile) you should use one of the alternative methods given below to move the profile. Although it is possible to rename the existing profile in the Profile Manager and then follow the steps below, if you make a mistake and then attempt to delete the new profile, data loss could occur (bug 113203).

  1. Completely close Mozilla Suite/SeaMonkey 1.x
  2. Copy the <Profile name> folder (which will contain the xxxxxxxx.SLT folder) to wherever you want to store it, as long as no other folder with the same name exists in that location. You can copy it anywhere except the application's program directory.
  3. Start the Profile Manager.
  4. Click on "Create Profile..." and, in the dialog that opens, enter the new profile name, using the EXACT same name as the <Profile name> folder you copied. For example, if you are copying the MyProfile\xxxxxxxx.SLT folder, enter MyProfile as the new profile name.
  5. If you placed the <Profile name> folder in the default profile location, click "Finish" to create the new profile.
  6. If you placed the <Profile name> folder in a different location:
    • Click on the "Choose Folder..." button. A "Browse for Folder" dialog will open.
    • Select the folder that contains the <Profile name> folder you copied. For example, if you placed the <MyProfile> folder inside the D:\Mozilla\Profiles folder, select the "Profiles" folder.
  7. Review the path shown in the "Completing the Create Profile Wizard" dialog to make sure it is correct, then click "Finish" to create the new profile.
  8. Select the new profile and press the Start button to start Mozilla Suite/SeaMonkey 1.x.
  9. Open a Mail & Newsgroups window and check that you can see the folders for each account. If they're missing, go to "Edit -> Mail & Newsgroups Account Settings -> Local Folders" and "Edit -> Mail & Newsgroups Account Settings -> Server Settings" for each of your accounts, then use the "Browse" button to specify the correct account and mail directories.

Other ways to move your profile

Finding your current profile

Regardless of the methods used, you will need to find the folder containing your profile. Beginning with Firefox 3.6 you can open your profile folder via "Help → Troubleshooting Information..." by clicking "Open Containing Folder" (click "Show in Finder" to find your profile on Mac OS). For more information see Finding the profile folder on Windows and Show hidden files and folders.

Create a new profile and copy the old one over it

  1. Create a new profile in the desired location.

    If you're installing the Mozilla application for the first time on a new PC and want to store the profile in the default location all you need to do is start the application. That will create a default profile. If you're running Thunderbird there is no need to answer any of the questions the account wizard asks, since you're not going to keep that data anyways.

  2. Exit the Profile Manager or completely close your Mozilla application, if open.
  3. Open the profile folder for the newly-created profile and remove its contents, which will consist of a small set of files that contain program defaults.
  4. Copy the contents of the old profile folder (its files and subfolders) into the new, now empty profile folder. For example, if you are copying the "default" profile to a new location:
    • Firefox, Thunderbird and SeaMonkey 2: Copy the contents of the xxxxxxxx.default folder and place them inside the new <profilename> folder.
    • Mozilla Suite and SeaMonkey 1.x: Copy the contents of the default xxxxxxxx.slt folder and place them inside the new <profilename> xxxxxxxx.slt folder
  5. If you're using SeaMonkey or Thunderbird, check that you can see the folders for each account. If they're missing, use the "Browse" button for the local directory in Tools -> Account Settings -> Server Settings and Tools -> Account Settings -> Local Folders to specify the correct account and mail directories.

Create a new profile and migrate your old data

Create a new profile in the desired location and then copy selected data from the old to the new profile.

If you're using Thunderbird or Mozilla Suite/SeaMonkey Mail, you should include the prefs.js file (otherwise, you will need to recreate your mail accounts). Once you start your Mozilla application with the new profile, you should then check that you can see the folders for each account. If they're missing, use the "Browse" button for the local directory in your (Mail & Newsgroups) Account Settings -> Server Settings and (Mail & Newsgroups) Account Settings -> Local Folders to specify the correct account and mail directories.

Modify profiles.ini to point to the new location - Advanced

Firefox, Thunderbird and SeaMonkey 2

Note: This method does not apply to Mozilla Suite/SeaMonkey 1.x, which uses a different system for keeping track of profiles.

Firefox, Thunderbird, or SeaMonkey 2 should already be installed on the computer where you are moving the profile and a profile folder and profiles.ini file should already exist. This method is recommended for advanced users only since it can be tough to troubleshoot. Mozilla applications can be very finicky about the contents of the profiles.ini file. They normally do not ignore bad entries, regardless of their position in the file.

  1. Create a new, empty folder in the desired profile location with the name you wish to use for the new profile, for example, D:\Mozilla\Firefox\Profiles\newprofile
  2. Copy the entire contents of the profile folder you are moving into the new profile folder you just created.
  3. If you copied the old profile from a CD, remove the write-protection from the copied files.
  4. Find the profiles.ini file (it will be located in the default profile folder path) and open it in a text editor.
    • (Optional) Change the "Name=" line to the name of the new profile folder you created, e.g., Name=newprofile
    • Change "IsRelative=1" to "IsRelative=0" (non-relative/full path)
    • Change the "Path=" line to the actual location of the new profile folder, e.g., Path=D:\Mozilla\Firefox\Profiles\newprofile. If you're using Windows non-relative paths use back slashes while relative paths use forward slashes so you may need to change the direction of the slashes too.
  5. If you are moving a profile from its default location, the original profile folder can now be removed.
  6. If you're using Thunderbird, check that you can see the folders for each account. If they're missing, use the browse button for the local directory in Tools -> Account Settings -> Server Settings and Tools -> Account Settings -> Local Folders to specify the correct account and mail directories.

Caution: Incorrect editing of the "profiles.ini" file can cause a "already running but is not responding" error if the profile cannot be found (bug 278860).

Troubleshooting

Firefox, Thunderbird and SeaMonkey 2

If some add-ons don't work after moving your profile, open the profile folder and delete these files (they will be regenerated): [1]

  • compreg.dat
  • extensions.cache
  • extensions.ini
  • extensions.rdf
  • pluginreg.dat

If the GUI looks strange (for example the toolbar buttons) or the application does not function properly, it could be due to interference from previously installed themes or extensions that you migrated along with the rest of your profile. Firefox, Thunderbird and SeaMonkey 2 users can try starting up in Safe Mode, which will launch the application with extensions and themes disabled; if the application starts up OK, then extensions/themes are most likely the problem. In this case, you can try exiting the application, deleting the contents of the "chrome" and "extensions" subfolders in your profile folder, and restarting. [2] Be warned that doing so will cause you to lose all installed extensions and themes.

You can verify whether your profile works by launching the application with the -profile "path" command line argument to specify which profile should be run (see this article for details). That won't solve your immediate problem but it lets you rule out anything that's not profile manager related.

The profile manager can be very finicky about the contents of the profiles.ini file. It normally does not ignore bad entries, regardless of their position in the file. Worst case you might need to delete the profiles.ini file (or move it to a safe location) and then move all your profiles. However, this typically isn't a risk unless you're moving a profile in order to recover a missing profile, or you edited the profiles.ini file manually.

See also