MozillaZine

Talk:Extensions.checkCompatibility

From MozillaZine Knowledge Base

Removal of recently added Mozilla Firefox 4.0 and above section

Is there a bug report or other reference to confirm that extensions.checkCompatibility.<version> doesn't work in Firefox 4.0 pre-release builds? I removed the recently added "Mozilla Firefox 4.0 and above" section (see below) pending that information. (I've added the extension link under "External links".) Using extensions.checkCompatibility.4.0b seems to work fine with my pre-release (Minefield) build of Firefox 4.0b2. UA: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:2.0b2pre) Gecko/20100630 Minefield/4.0b2pre


==Mozilla Firefox 4.0 and above==

Add-on Compatibility Reporter extension appears to be the only way for Beta testers of 4.0 to test "incompatible" addons, which will be remarked as "Compatibility". Those marked in red as "Incompatible with Firefox v.vxx" have not been marked as compatible by it's author and you should mark those as "This add-on still works" or "This add-on no longer works" (as it did before). If "no longer works" add your comment.


Looking at the comments section of that extension, it look like it's the extension that doesn't work in 4.0 Beta. If it's an extension issue then that information doesn't really belong in this article. Alice 11:32, 13 July 2010 (UTC)

extensions.checkCompatibility.4.0b does work in 4.0.b2pre without or with the extension as someone else pointed out Minefield 4.0b2pre, what happened to 3.7a2pre. I'm not sure of exactly what was not working now, but I found most of my existing plugins disabled and could not be enabled, except by reinstall. Whatever that was, hope I don't have to go through that again with a Firefox update or at least find out what was going on. The extension was updated and is working in 4.0b2pre quite nicely (was maybe slightly delayed, could not resolve my problems for a day and it may or may not have been involved). The extension did not work in 4.0b1 (short-lived version), which preceded automatic Minefield change from 3.7a2pre to 4.0b2pre .
I was hoping to find out quickly what actually happened and to remove or hopefully modify what I added because the extension is helpful for beta testing and getting things quickly resolved helps everybody especially those that won't have the override.
Add-on Compatibility reporter collects tester responses based on an extension's GUID (obtainable from Troubleshooting Information...) and reported problem notes can be seen if logged in at top of report, example of a report DMcRitchie 14:49, 13 July 2010 (UTC)
and it's a pity that it doesn't support SeaMonkey. Maybe I should add a <!-- SeaMonkey --> or even <!-- Toolkit --> section in the install.rdf, and see what happens. — Tony 16:48, 13 July 2010 (UTC)

UI section

If the "Mozilla Firefox 4.0 and above" section was supposed to be about the UI being gone in Firefox 4 pre-release builds, then it wasn't clear and it should have been written as a level-three heading, as part of the UI section. What I did was simply edit the "Mozilla Firefox 2.0 and above" section, with a note the the UI no longer exists in Mozilla Firefox builds after 3.6. I don't have a reference but I can confirm that, even though the preference works to allow the incompatible extension to function, the UI "Enable" button to re-enable the compatibility check no longer exists in Firefox 4.0b2pre or in 3.7a5 Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5) Gecko/20100610 MozillaDeveloperPreview/3.7a5 (screenshot). Alice

Regards the screenshot, it appears that I had to reinstall all of the extension except possibly for those that the the author had marked as compatible in the Compartibility Reporter. In any case I do think that my additions concerning how to install an addon from addons.mozilla.org is relevant because one would hardly look here unless they had trouble installing an addon, so I don't understand the removal (by HTML comment) by Tonymec. — DMcRitchie
My main reason for commenting out was that the present article applies to any extensions, not just those found at AMO; and explains how to make them installable and enable-able by means of an about:config setting, not by means of an auxiliary extension — MoCo seems to be pushing the "Compatibility Reporter" extension, which BTW does not support SeaMonkey; but I could just as well have mentioned the "MR-Tech Toolkit" extension, which has a long and successful track record, and supports all Toolkit applications. But neither of these two extensions are the subject of the present knowledge base article. If you haven't yet understood, and assuming you are using Firefox 4.0, the procedure is as follows:
  1. Type about:config in the URL Bar and hit Enter
  2. If you get a warning screen, tick "I'll be careful".
  3. Right-click anywhere, then New => Boolean
  4. Name: extensions.checkCompatibility.4.0 then [ OK ]
    For a different application version, the name will be slightly different.
  5. Value: false then [ OK ]
Any extensions disabled previously because of a version mismatch are still there, no need to reinstall them: you can now reenable them via the addons manager. But since from then on, Firefox will neither disable "incompatible" extensions (i.e. extensions supporting only a different Firefox version), nor refuse to install them, it becomes your responsibility to manually disable any misbehaving extension (again, via the addons manager).
I didn't just remove the contentious paragraph to avoid a "holy war" of back-and-forth editing, and so that someone more in the know than both you and me could arbitrate by either removing your text completely, or reestablishing it — preferably after reaching a consensus by discussion. Tony 02:08, 20 July 2010 (UTC)
I agree with Tonymec. The paragraph should be removed. Category talk:Preferences has a guide for what belongs in articles in the Preferences category, like this one. For the purposes of this article, adding or removing Extensions.checkCompatibility.* preferences. is done via about:config or the UI, when it exists, not through an added extension. If someone wants to add information about using an extension to test add-on compatibility then it should be in a different article ... maybe Testing pre-release versions (under Using Add-ons) and/or Updating add-ons? Alice 17:32, 20 July 2010 (UTC)
Since there has been no more discussion, I removed the wiki note and contentious paragraph from the article. I also replaced the "External links" section with the Add-on Compatibility Reporter link with a "See also" section that links to Updating add-ons#Extensions that force compatibility which now discusses that extension. Alice 14:56, 30 July 2010 (UTC)