MozillaZine

Standard diagnostic - Firefox

From MozillaZine Knowledge Base

This article provides a more or less complete set of steps to identify and correct most known causes of Firefox no longer working properly. The solutions offered will preserve your user profile data (bookmarks, passwords, history, preference settings, etc.) as far as possible. You should first search the Knowledge Base and check the links given at the end of this article for a solution to your specific problem. If you find one, this will take less time than working or even reading through all the diagnostic steps presented here. The advantage of using this standard diagnostic is that the order of the steps helps narrow down where the problem is.

Important: The Firefox configuration, bookmarks and other personal data, and information on themes and extensions are stored in your profile. Uninstalling and reinstalling does not change the profile data, and therefore may not solve the problem.

Contents

Standard diagnostic steps

Note: Many "Firefox" problems are caused by incompatible themes, extensions, or programming errors in plugins. As a quick diagnostic, you may wish to switch to the default theme or, if the problem appeared after installing a new extension or after upgrading Firefox, use the Add-ons manager (accessible from the Firefox or Tools menu) to update or disable your extensions, and disable plugins, before going through the diagnostic steps below. Starting with Firefox 13, you can alternately use the Reset Firefox option from the Troubleshooting Information page if you want to try a quick fix and don't mind losing your extensions or customized settings (see the linked articles for details).

  1. Exit Firefox completely and reboot the computer.
  2. (If you can open Firefox and use the menus) clear the cache: "Tools -> Options -> Advanced -> Network / Offline Storage -> Clear Now" and clear any other private data you don't wish to save such as cookies and download history; if the problem isn't resolved, then:
  3. Close Firefox (if open) using "File -> Exit" and make sure it is not running in the background (on some systems, you may need to wait awhile for the Firefox process to terminate). Optionally make a profile backup to safeguard your data and settings and then:
  4. Customization and preference issues: Open the Firefox profile folder, then close Firefox (if open) and rename the localstore.rdf file (this will remove any toolbar customizations) and also rename the prefs.js file (this will remove any user-set preferences and restores the default theme) and then restart Firefox. See Corrupt localstore.rdf and Resetting preferences for more information. The renamed files can be used as backups, if you later want to reverse the changes. Note: In Firefox 14 and below, you can alternately restart in Firefox Safe Mode, check the "Reset toolbars and controls" and "Reset all user preferences to Firefox defaults" options, then press the "Make Changes and Restart" button, but you will not be able to reverse your changes unless you saved a profile backup. If the problem is not resolved,
  5. Extension and theme issues (and hardware acceleration in Firefox 4 and above): Check the list of problematic extensions, to see if your problem is listed; if not, start Firefox in Safe Mode and, when the "Firefox Safe Mode" window appears, press the button, "Continue in Safe Mode" (Firefox 14 and below) or "Start in Safe Mode" (Firefox 15 and above). If the problem persists in Safe Mode, continue with the next numbered step. If the problem goes away in Safe Mode:
    • (Firefox 4 and above) Turn off hardware acceleration ("Tools -> Options -> Advanced / General -> Use hardware acceleration when available")
    • Update or uninstall the added theme or select the default theme in "Tools -> Add-ons -> Themes".
    • Update, disable, or uninstall your added extensions via "Tools -> Add-ons -> Extensions" (see Extension issues below).
  6. Profile issues: Create a new Firefox profile (You can later use the Firefox Profile Manager to return to your original profile). If the problem goes away in the new profile, you can either selectively copy your important profile data to the new profile and reinstall your added extensions and themes or you can try to fix the original profile (see below). If the problem is not resolved in a new profile:
  7. Plugin issues: You can disable your plugins to see if the issue is plugin-related. See Plugin issues below for details. In Firefox 3.0 and above, use the Add-ons manager ("Tools -> Add-ons -> Plugins") to disable each plugin. If the problem persists:
  8. Clean reinstall: Download a new Firefox installer from Mozilla.org and then close Firefox completely, delete the Firefox installation directory and reinstall Firefox. If this does not help, you may need to uninstall Firefox completely before reinstalling it. See Clean reinstall below for details.

If the issue is still unresolved, see the other solutions listed below.

Extension issues

Extension problems may arise after a Firefox update, not just after installing a new extension. In that case, it's impossible to know which extension is the culprit (due to its lack of compatibility with the new Firefox version). It may be enough to just update all the extensions in "Firefox (or Tools) -> Add-ons -> Extensions -> "gear wheel" icon -> Check for Updates". Otherwise, the quickest solution to many Firefox problems is to check whether disabling all extensions helps.

  1. Start Firefox in Safe Mode (not Windows Safe Mode). When the "Firefox Safe Mode" window appears, press the button, "Continue in Safe Mode" (Firefox 14 and below) or "Start in Safe Mode" (Firefox 15 and above). This will start the program with all extensions disabled and with the default theme. In Firefox 4 and above, Firefox has simplified starting in Safe Mode with Help ("Alt+H") > "Restart with Add-ons disabled" to restart immediately (one-time) in Safe Mode.
  2. If the problem disappears when all extensions are disabled, restart Firefox normally and disable about one half of the extensions. Open the Extensions list via "Firefox (or Tools) -> Add-ons -> Extensions", then select each extension and click the "Disable" button. Restart Firefox.
  3. If the problem is still gone when you restart Firefox, the buggy extension is among the ones you disabled. Note these down, and then enable about half of them.
  4. Restart Firefox and keep narrowing down the number of suspects in the same way of always halving the number of suspects. If the "Firefox" problem comes back at any point in this detective process, you know that there is at least one buggy extension in the group you just enabled, but keep in mind that there could also be other buggy ones among the group you disabled. (So the only way of making sure that you find all buggy extensions is to only ignore those groups that did not cause any problems when enabled.)

You will probably want to uninstall any extensions found to be "buggy"; however, if the extension is important to you, you may want to see if reinstalling it (after first uninstalling it) solves the problem. Other alternatives are to keep it disabled and to regularly check for updates. You might also want to send the author a friendly note, and first check if s/he has a newer version on her/his site than where you got it from. Keep in mind that many extension authors are not professional programmers, and all do something else for a living than writing Firefox extensions. They may not even know that their extension is buggy, or they may need a reminder to find time to fix their extension.

Another approach at identifying the extension based on recently updated extensions. (Firefox 4.0 and up)
If you've been on the same version of Firefox for awhile and the problem just started happening, then try "Firefox (or Tools) > Add-ons > Extensions" then click on the gear wheel choose "View Recent Updates". To see list in normal fashion again choose "Appearances" then return to "Extensions".

Profile issues

If you wish to diagnose all profile-related issues (which include extension and theme issues), you can do so by creating a new Firefox profile (do not delete the original profile, just create a new one). Your added extensions and themes, bookmarks and other personal data and settings will not be present when Firefox starts with the new profile but will still be available in the original profile. If the problem still exists in the new profile, complete the remaining standard diagnostic steps.

If the problem is resolved in the new profile, you have two options:

  1. You can migrate your data and settings by selectively copying your important profile data to the new profile, then reinstall your added extensions and themes or,
  2. You can try to fix the problem in the original profile, as outlined below.

To fix the problem in the original profile

You may be able to fix the original profile by removing certain files in the original Firefox profile folder, as suggested below. (First make sure you have a current profile backup so that no data is lost.) After each step, use the Profile Manager or a shortcut to the original profile to reopen Firefox using the original profile, to see if the problem is resolved. If it isn't, make sure you exit Firefox completely before continuing.

  • Look in your original Firefox profile folder for multiple numbered copies of the same file (e.g., "sessionstore-n.js" or "prefs-n.js") where "n" is a number, for example, "sessionstore-999.js". Delete the numbered copies, if found. (Caution: Do not delete the dated bookmarks files in the bookmarkbackups folder - these are bookmark backups.) Next, check the properties of the original profile folder and its file contents. Remove any "read-only" attributes that may exist. If you find ".moztmp" files such as "prefs.js.moztmp", remove the read-only attribute or delete the file. See Multiple profile files created for details.
  • Delete (or rename) the files "xpti.dat" "compreg.dat" "extensions.ini" "extensions.cache", "extensions.rdf" and "pluginreg.dat" from your original Firefox profile folder. These files contain information about Firefox add-ons and components and will be regenerated.
  • Delete (or rename) the files "mimeTypes.rdf", cookies.txt and/or "cookies.sqlite", hostperm.1 and/or "permissions.sqlite", and "localstore.rdf" from your original Firefox profile folder. This will remove changes to filetype download actions, cookies, "Exceptions" lists for cookies, popups, images, etc., and any changes you have made to the toolbars (these files can be later restored from backup or renaming, if removing didn't help).
  • Delete (or rename) the files "prefs.js" and (if present) "user.js" from your original Firefox profile folder. This will remove your customized preference settings contained in these files.
  • Remove the "extensions" folder and the "chrome" folder (if present) from your original Firefox profile folder. This will remove all of your extensions and themes and any usercontent or userchrome customizations you may have made.
  • Delete the files "XPC.mfl and "XUL.mfl" (Windows), "xpc.mfasl" and "xul.mfasl" (Linux), or "XPC FastLoad File" and "XUL FastLoad File" (Mac OS X) [1] either from the original Firefox profile folder or from the "profile temp directory" that also stores the "Cache" folder for the original profile. [2] Check under %USERPROFILE%\Local Settings\Application Data\Mozilla\Firefox\Profiles in Windows 2000/XP, under %USERPROFILE%\AppData\Local\Mozilla\Firefox\Profiles in Windows 7/Vista or under ~/Library/Caches/Firefox in Mac OS X. It will be regenerated on next startup.
  • (Firefox 3 and above) Remove "places.sqlite" (and "places.sqlite-journal", if found) from your original Firefox profile folder to a backup location, to rule out a damaged Places database. This will remove your browsing history and restore bookmarks from the most recent JSON bookmark backup.

Plugin issues

Plugins are enabled by default in all Firefox profiles. To view a list of installed plugins that Firefox is detecting, enter about:plugins in the Location Bar (address bar). Common plugins include Java, Flash, Adobe Reader, Quicktime and Windows Media Player. See the linked articles and read Issues related to plugins for troubleshooting suggestions and additional information.

In Firefox 3.0 and above, you can view, disable, and enable plugins via "Tools -> Add-ons -> Plugins". To see if a plugin is causing the issue, select it in the Add-ons window and click the Disable button. Note that disabled plugins are removed from the about:plugins list of detected plugins. To re-enable a disabled plugin, select it in the Add-ons window and click the Enable button.

Clean reinstall

Reinstalling Firefox after first removing the installation directory (the application or program folder) is called a "clean reinstall". This will resolve some Firefox issues related to its program files, including files from previous Firefox installs or updates and, in some cases, files added to the Firefox program folder by other software. [3] [4] [5]

You can do a clean reinstall of Firefox as follows:

  1. Use any browser to download the Firefox installer from mozilla.org (or from here) and save it to your desktop or other location. (Avoid unofficial download sites.)
  2. Close Firefox completely (if open).
  3. Delete the Firefox installation directory (On Windows, this is typically the C:\Program Files\Mozilla Firefox or C:\Program Files(x86)\Mozilla Firefox folder that contains "firefox.exe" and other Firefox program files and folders).
  4. Reinstall Firefox by running the installer you downloaded previously.

Another "clean reinstall" method is to first uninstall Firefox (on Windows, do not select the uninstall option, "Remove my Firefox personal data and customizations", unless you want to remove your user profile data) and then reinstall Firefox into a different program folder. (On Windows, use the "Custom" Setup Type and choose a different Destination Folder, e.g., C:\Program Files\Firefox). [6]

Reinstall after completely removing Firefox

If the problem persists, or if you would rather completely remove Firefox and start over, follow these steps:

  1. Download the Firefox installer from Mozilla.org (or download from here for the previous version).
  2. Make a backup copy of your Firefox profile folder as a precaution and then:
  3. Completely remove your current version of Firefox, following the instructions in the Uninstalling Firefox article.
  4. Important: If you want Firefox to start up fresh, as though it was never installed before, also remove your user profile data.
  5. Reinstall Firefox by running the installer you downloaded previously.

If you removed your user profile data before reinstalling Firefox, it will start up with the Import Wizard, just as if you installed it for the very first time, and a new "default" profile will be created. You can then close Firefox and can selectively copy back your important profile data into the new profile and reinstall your extensions or themes.

Other solutions

  • Check your firewall or other security software settings to ensure that Firefox or specific web content is not being blocked.
  • An ad-blocker, web-accelerator, antivirus or other running program may be conflicting with Firefox. Try temporarily disabling these other programs one at a time. [7] [8]
  • There may be a problem with your hosts file - see Error loading websites for more information on this and other causes of blocked websites.
  • (Windows 2000 and above:) Run the Check Disk error-checking tool (explained here and here) and fix any disk errors found. (Windows Me and below: Run ScanDisk.)
  • With Firefox completely closed, open the application folder (by default, C:\Program Files\Mozilla Firefox on Windows) rename firefox.exe to firefox1.exe, then double-click firefox1.exe. If Firefox runs without problems, it could indicate that your firewall is blocking Firefox [9] (read the Firewalls article!). It may also indicate that some malicious code has targeted Firefox [10]. Note: If firefox.exe is always open, specific malware may have targeted Firefox if it is set as the default browser.

Check for malware

Scan your system for viruses, spyware and other malware (malicious software). Your installed security software may not detect the malware so you should also use these specialized malware removal tools: [11] [12] [13]

You can post in one of these forums for malware removal help:

Other recommended malware removal forums are listed here.

Note: Sometimes it can be (practically?) impossible to clean up a malware infection. [14]

See also