MozillaZine

Saving and detaching attachments

From MozillaZine Knowledge Base

When you receive an attachment—for example, Word documents or photos—Thunderbird keeps it with the e-mail message the attachment came with unless you remove it. To open or view an attachment, delete it, or to save it as a separate file, find the e-mail message it came with and right-click on the attachment at the bottom.

Contents

Saving attachments

To save attachments for a single e-mail message, you can use any of these methods:

  • Right-click on the attachment name or icon in the "Attachments" pane, at the bottom of the window, and choose "Save As..." (to save only the selected attachment) or "Save All..." (to save all attachments at once). In the dialog box that pops up, you can choose where on your computer you would like to save the attachments.
  • Using the "File" menu: look under "File -> Attachments" for the "Save As..." and "Save All..." options.
  • Using your mouse, select an attachment in the Attachments pane and drag it to your Desktop.
  • Double-click on the attachment in the Attachments pane. See Actions for attachment file types for further details.

Separating attachments from messages

Beginning with version 1.5, Thunderbird allows you to detach or delete attachments from messages. As opposed to saving an attachment, these actions remove the attachment from the message. (See Bug 2920 for the background). To detach or delete one or more attachments, you can either:

  • Select an attachment in the Attachments pane, right-click, and choose "Detach", "Delete", "Detach All", or "Delete All".
  • Select a message in the message-list pane, go to "File -> Attachments", and choose one of the detach/delete options.

In Thunderbird 1.0x, there is no built-in means to detach or delete an attachment without deleting the entire message itself. You can try the Thunderbird Attachment Tools extension, however.

Technical details

Most e-mail programs use MIME to attach files to e-mails. MIME converts the file to a format compatible with Internet transmission (i.e. "encodes" it) and attaches it to text of the message, creating one large e-mail. Then the whole e-mail, including the attachment, is sent together.

Thunderbird stores the whole e-mail together, including the attachment, in MIME format in the mailbox files in your Profile folder - Thunderbird. It does not un-encode and store the attachment outside the mailbox file unless you save or detach it as described above. By contrast, the Eudora e-mail program automatically un-encodes and detaches the attachment when you receive the e-mail; it always stores attachments as separate files.

To see an e-mail attachment after MIME processing, send an e-mail with an attachment, then in your Sent folder highlight the e-mail you sent and click "View -> Message Source".

Attachment Extractor extension

The Attachment Extractor extension provides many more features. This includes the ability to filter what attachments should get extracted based on the file name extension. You could use that to extract just the image files in a message or a folder.

See also

External links