MozillaZine

Mozilla Crash Reporter

From MozillaZine Knowledge Base

Starting with Firefox 3, Thunderbird 3, and SeaMonkey 2, Mozilla applications use an open source crash reporting system that incorporates the Breakpad crash reporting tool developed by Google engineers and the Socorro web server for processing crash report data. Mozilla's new crash reporting system (also known as "Breakpad") and the Mozilla Crash Reporter user interface replace the old Quality Feedback Agent (aka "Talkback") reporting system that was used in previous Mozilla applications.

Contents

Mozilla Crash Reporter

Image:MozillaCrashReporter-Fx7.png

Crash Reporter is a core part of program installation in Firefox 3.0, Thunderbird 3, and SeaMonkey 2.0 and above. Unlike the "Talkback" global extension in earlier Mozilla applications, it cannot be deselected during custom Windows install [1]. The crash reporter tool, "crashreporter.exe" on Windows, "crashreporter.app" on Mac OS and "crashreporter" on Linux, is located in the program's installation directory.

When your Mozilla application crashes, it saves a binary "dump" file and you will see a notification, similar to the one shown here. This Crash Reporter allows you to submit a crash data report to a web server. The Socorro-based web server at crash-stats.mozilla.com is used to search and view crash report data.

Can I disable Crash Reporter?

Mozilla Crash Reporter is enabled by default and there is no user interface to disable it. Advanced users who prefer the standard application error notifications (e.g., the Windows error dialog "<application> has encountered a problem and needs to close" and Event Viewer record) can disable the Mozilla Crash Reporter by adding a system environment variable named MOZ_CRASHREPORTER_DISABLE and setting its value to 1. [2] [3] Note: Another method to disable the Mozilla Crash Reporter was to open the "application.ini" file in the installation directory, find the entry [Crash Reporter] Enabled=1 and change the 1 to 0 (repeating the edit if an application update replaces the file) but this may no longer work since the fix for bug 686466.

Note: Unchecking the "Submit crash reports" option/preference (e.g., in Firefox Options -> Advanced / General (tab), under "System Defaults") does not turn off the Crash Reporter; it simply toggles the default of the "Tell Mozilla about this crash so they can fix it" check box in the Mozilla Crash Reporter dialog (upon crash). On Windows XP you need to modify the registry; otherwise, this setting is not saved and the "Submit crash reports" option will again be checked when you next restart your Mozilla application. The value SubmitCrashReport needs to be set in HKEY_LOCAL_MACHINE\Software\Mozilla\Firefox\Crash Reporter for all users and HKEY_CURRENT_USER\Software\Mozilla\Firefox\Crash Reporter for a single user. When the DWORD value of SubmitCrashReport is 0, the Crash Report will not be submitted. [4] [5] [6]

Why didn't Breakpad capture my crash?

In some installations with a problematic plug-in or an old operating system library, a Mozilla application may crash but no "dump" file is captured, so the crash reporter is unable to report the crash. Also, crash reporter does not work for applications built for and run in 64 bit mode. See Alternative ways to get a stacktrace, and fixes or workarounds listed at Related bug reports that may enable it to capture the dump file in the future. To test whether cash reporter is working for you, install crashmenow add-on, run it from Tools to crash your application, then Attempt to find the report. If you can't find at with your crash report id at crash-stats then it's likely it's not getting submitted to the crash server and it's stuck in your profile's "pending" directory.

Location of crash reports

The "Crash Reports" directory has two folders: pending for crash reports that haven't yet been submitted to the server yet, and submitted for reports that have been sent. "Crash Reports" folder locations are shown below. (On Windows, Linux, and starting in Mac OS X 10.7, you may need to show hidden files and folders to navigate to these locations, which are hidden by default).

Firefox

  • Windows: Open %APPDATA%\Mozilla\Firefox\Crash Reports\ from a Windows Run or start search box or navigate to the folder location shown below:
Windows 7/Vista: C:\Users\<username>\AppData\Roaming\Mozilla\Firefox\Crash Reports\
Windows XP/2000: C:\Documents and Settings\<username>\Application Data\Mozilla\Firefox\Crash Reports\
  • Mac OS: /Users/<username>/Library/Application Support/Firefox/Crash Reports/
  • Linux: /home/<username>/.mozilla/firefox/Crash Reports/


SeaMonkey

  • Windows: Open %APPDATA%\Mozilla\SeaMonkey\Crash Reports\ from a Windows Run or start search box or navigate to the folder location shown below:
Windows 7/Vista: C:\Users\<username>\AppData\Roaming\Mozilla\SeaMonkey\Crash Reports\
Windows XP/2000: C:\Documents and Settings\<username>\Application Data\Mozilla\SeaMonkey\Crash Reports\
  • Mac OS: /Users/<username>/Library/Application Support/SeaMonkey/Crash Reports/
  • Linux: /home/<username>/.mozilla/seamonkey/Crash Reports/


Thunderbird (reference Thunderbird profile location)

  • Windows: Open %APPDATA%\Thunderbird\Crash Reports\ from a Windows Run or start search box or navigate to the folder location shown below:
Windows 7/Vista: C:\Users\<username>\AppData\Roaming\Thunderbird\Crash Reports\
Windows XP/2000: C:\Documents and Settings\<username>\Application Data\Thunderbird\Crash Reports\
  • Mac OS: /Users/<username>/Library/Thunderbird/Crash Reports/
  • Linux: /home/<username>/.thunderbird/Crash Reports

Viewing crash reports

Using the application to view crash reports

Crash reports are stored and analyzed at mozilla crash reports, aka crash-stats. Crash reports are linked from the about:crashes "Submitted Crash Reports" page, which you can open from your Mozilla application. (If you can't start the application or don't find the crash report this way, see Using the file system to view crash reports, below.)

  1. Open the "Submitted Crash Reports" page using one of these methods:
    • In Firefox or SeaMonkey, type about:crashes in the address bar
    • Open the Troubleshooting Information page from the Help menu and click the about:crashes link
    • Install the ViewAbout extension for Thunderbird, for Firefox,for SeaMonkey; restart the app. then go to View | ViewAbout | about:crashes
    • In the Code: line of the Error Console, type openDialog("about:crashes"); and, to the immediate right, click Evaluate.
    • In Thunderbird, use "Tools -> Options -> General -> Location", type about:crashes and click OK. Then do Go, Mail Start Page
  2. In the about:crashes display (shown below in Firefox) , click on a crash link to view the data at crash-stats. If the link isn't prefixed with bp-, then the crash didn't successfully submit to crash-stats. Clicking the link will attempt to submit your crash. Report IDs are of the form bp-<guid> where the last 6 characters of <guid> are a date.
    Image:SubmittedCrashReports.png
  3. Crash-stats will show reported bug numbers if any bug summaries match the crash signature. If crash-stats does not show a bug number, please file a bug report. In the bug, include the crash Report ID, and in the bug summary title provide the crash signature formatted as "crash [@ <signature>]", where <signature> is copy and pasted from crash-stats.
  4. If you can add helpful information to the bug please do so. This might include clear steps to reproduce, and whether you can reproduce in Safe Mode.

Using the file system to view crash reports

You can also use the files stored on your computer when a crash report is submitted, to locate and view the report. This can be useful if your Mozilla application will not open or crashes at startup and you cannot access the Submitted Crash Reports list.

Each submitted crash report is identified as a text file, located in the "Crash Reports" folder within the "submitted" subfolder (see Location of crash reports, above). Files are named bp-GUID where GUID is a unique identifier and functions as the report's ID. You can open the text file for a given crash report to view its contents.

For example, in older version crash reports, a file "bp-3c2a9b80-a143-11dd-8241-001cc4e2bf68.txt" created 10-28-2008 may contain the following text:

Crash ID: bp-3c2a9b80-a143-11dd-8241-001cc4e2bf68
You can view details of this crash at 
http://crash-stats.mozilla.com/report/index/3c2a9b80-a143-11dd-8241-001cc4e2bf68

Text files for submitted crash reports (at time of writing) may now include only the Crash ID, without a URL. For example, a file "bp-031b02bb-26b6-4168-ac0e-2de492090531.txt" created 5-31-2009 may contain only the following text:

Crash ID: bp-031b02bb-26b6-4168-ac0e-2de492090531

Append the GUID portion of the Crash ID to the Breakpad report URL (currently http://crash-stats.mozilla.com/report/index/) and go to that URL to view the crash report (e.g., http://crash-stats.mozilla.com/report/index/031b02bb-26b6-4168-ac0e-2de492090531).

Referencing crash reports in Bugzilla

Comments in Bugzilla should reference crash reports using the Crash ID, bp-GUID, including the "bp-" prefix before the GUID; for example, bp-031b02bb-26b6-4168-ac0e-2de492090531 (see above). Crash reports referenced in this way are linked by Bugzilla to the correct report at http://crash-stats.mozilla.com/

See also

External links

Related bug reports