MozillaZine

Make Thunderbird 3.1 look like Thunderbird 2

From MozillaZine Knowledge Base

This article describes how to configure Thunderbird 3.1.* to have Thunderbird 2.0.0.24's look and feel. It is useful if you are considering downgrading from 3.1 to 2.0.0.24 or if you are upgrading another person and don't want them to have to deal with a lot of new concepts / changes.

It is possible to restore a lot of the Thunderbird 2.0.0.24 look and feel, but there are limits. Some of the (more annoying) things you can't change are:

  • The new account wizard (this shouldn't be an issue since you already have a profile)
  • You can't completely get rid of the new message viewer (though you can come close)
  • The new terminology used in Tools -> Account Settings
  • Auto-complete using both the main and additional email address
  • How (non-global) search works

To compensate, Thunderbird has many bug fixes, the ability to run add-ons that require 3.1, and some minor 3.1 features that you might (or might not) want to keep. It is frequently possible to still run add-ons that don't support 3.0 or later (without modifying them). It is also a lot easier to get help if you're using a recent release rather than one that has reached end of life.

You don't have to make all of these changes - you can pick and choose the ones you like. Some of the changes will make Thunderbird use less memory, which will make it feel snappier (due to reducing the number of background processes).

Major changes

  • Click the ◄► arrows at the top of the folder pane, until you see All Folders ◄► . That will restore the old style folder pane.
  • Disable global searches (Gloda) by unchecking Tools -> Options -> Advanced -> General -> Enable Global Search and Indexer.
  • If you have an IMAP account you can prevent it from downloading messages to offline folders by unchecking Tools -> Account Settings -> Synchronization & Storage -> Keep messages for this account on the computer. This will disable global searches of message bodies in IMAP accounts as a side effect (if you didn't disable global searches).
  • You can add buttons to the toolbar at the top of the main window by right clicking on it, selecting Customize, dragging and dropping the buttons to the toolbar, and then pressing Done. Alternatively, the Migration Assistant (accessed via Help -> Migration Assistant) can be used to restore the old 2.0.0.24 main toolbar.

    You can remove any buttons you don't want in the message window toolbar (the new toolbar added to the message window) by right clicking on it, selecting Customize, and then dragging and dropping the buttons to the Customize Toolbar window. Press Done when you're finished. Unfortunately, you can't remove the "other actions" list box that way.

  • You can display messages in a window instead of a tab by selecting Tools -> Options -> Reading & Display -> Open messages in -> An exiting message window. You can disable all tabs (not just for messages but for the folder pane) by setting mail.tabs.autoHide true using the Config editor.
  • If you don't like the Quick Filter toolbar you can hide it by unchecking View -> Toolbars -> Quick Filter toolbar. Unfortunately there is a bug in how shortcuts are mapped that can cause either Edit -> Find -> Find in this message or the Quick Filter toolbar to execute when you press Ctrl+F, depending upon the circumstances (even if the Quick Filter toolbar is disabled). The Ctrl+G keyboard shortcut always opens Find in this Message, but then performs Find Again on subsequent searches without opening the search bar again.
  • You can often run add-ons that don't support your version of Thunderbird by bypassing the version checking. It depends upon what API calls the add-on makes. The safest way to do this is to install the Add-on Compatibility Reporter add-on. While it is mainly used to report problems with add-ons it automatically enables all extensions.

Minor tweaks

  • Thunderbird 2.0.0.24 used a [+] button to toggle between showing a complete list and just one line of addresses in a messages headers. Thunderbird 3.1 replaced that with a "more" button which may also use a vertical scroll bar. If you set mailnews.headers.show_n_lines_before_more to 0 using the Config Editor it will show a complete list and eliminate the vertical scroll bar. You can also set this preference to a maximum number of lines to display before showing the "more", though that can degrade performance.
  • Addresses in the headers are replaced with "You" if they match any of your identities (email addresses). This doesn't effect what the recipient sees or what is stored within the message, it only effects what your copy of Thunderbird displays. If you don't like this you can disable it by unchecking "Show only display name for people in my address book" in Tools -> Options -> Advanced -> Reading & Display.
  • The Archive feature added in Thunderbird 3 is not an automatic process. It is a quick way to manually move messages from a folder to a specific Archive folder. There isn't an option or setting to disable it yet. [1] [2]. In the interim, you could use the Message Archive Options add-on to change the shortcut key from A to Shift+A, Ctrl+A or Alt+A to avoid accidentally archiving a message. Another solution would be to use the KeyConfig add-on to completely disable the Archive key shortcut.

Advanced

Hide the message window toolbar

This hides the message window toolbar, the "other actions" list box, and moves the date from the right side back to the left. However, it does not move the Date: header between From: and To/CC like 2.0.0.24 has. It is still below the rest of the headers.

  • Start Thunderbird.
  • Enter mailnews.headers in the Filter using the Config Editor. Find mailnews.headers.extraExpandedHeaders and double click on it in the Value column. It may be empty or have something like list-post list-id list-help list-archive list-subscribe list-unsubscribe as the value. Change it to date.
  • Exit Thunderbird.
  • Create a Chrome directory in your Thunderbird profile using Windows Explorer.
  • Create a userChrome.css text file in it using a text editor such as Notepad. Don't use a word processor.
  • Copy and paste the following into it, and save the file.
@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");  
#header-view-toolbox,
#otherActionsBox {
 display: none !important;
}
#expandedHeaderRows {
padding-top: 0px !important;
}
#dateValueBox {
 display: none
}
  • Restart Thunderbird.

If this doesn't work check that the Chrome directory you created is in the same directory as the abook.mab and prefs.js files. If you don't see a abook.mab file check that you didn't accidentally use the Firefox profile. If its in the correct location try temporarily running in safe mode (not to be confused with Windows safe mode) to temporarily disable all add-ons to see if one of them is the culprit.

Move the Date back into the headers

This assumes you've already made the changes in the previous section. It will move the Date: header back into the headers between the From: header and the To/CC headers. It was tested against Thunderbird 3.1.6 but might break in future releases. Its trickier than the preceding changes.

  • Add #expandedHeadersBox {-moz-binding: url(chrome://userchrome/content/userChrome.xml#headers);} to the bottom of userChrome.CSS. Save the file.
  • Create a userChrome.xml text file in the same directory. This is the binding that moves the Date above the other headers.
  • Copy and paste the following into it, and save the file.
<?xml version="1.0"?>
<!DOCTYPE bindings >
<bindings xmlns="http://www.mozilla.org/xbl"
 xmlns:xul="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul">
<binding id="headers">
  <implementation>
    <constructor><![CDATA[
      var from = document.getElementById("expandedfromRow")
      var subj = document.getElementById("expandedsubjectRow")
      var date = document.getElementById("dateLabel")
    
      // new row for date...
      with (from.parentNode.appendChild(document.createElement("row"))) {
        with (appendChild(document.createElement("label")))
          appendChild(document.createTextNode("Date:")),
          className = "headerName"
          appendChild(date.parentNode.removeChild(date))
        }
      
     // mess with sequence...
      with (subj.parentNode)
        insertBefore(from.parentNode.removeChild(from), firstChild),
        appendChild(removeChild(subj))
      ]]></constructor>
    </implementation>
</bindings>
  • Restart Thunderbird.

See also

External Links