MozillaZine

Importing folders

From MozillaZine Knowledge Base

This article was written for Thunderbird but also applies to Mozilla Suite / SeaMonkey (though some menu sequences may differ).

This article gives step by step instructions for how to import folders from another profile for a new user who has never installed an extension. It assumes you're using Windows but you should still be able to follow the instructions using a file manager on another operating system. The extension can also be used to export folders, though this article doesn't describe how to do that.

Contents

Install the ImportExportTools extension

Thunderbird instructions

  • Go to this web page and click on the download now button. Choose "save file" and press the OK button to save the file when the popup asks what should Firefox do with that file.
  • Start Thunderbird.
  • Go to Tools -> Addons -> Extensions. Select the icon that looks like a gear (its actually a list box) near the top of the window and then "Install add-on from file".
  • Browse to where you downloaded the .xpi file, select it and press Open.
  • It will then display a "Software Installation" screen with a grayed out "Install" button. After a couple of seconds it will finish processing the .xpi file and replace that button with a "Install Now" button. Press the button.
  • Exit Thunderbird.
  • Start Thunderbird again. It should now have a Tools -> ImportExportTools -> "import mbox file" command. Don't use it yet, just check that it exists.

SeaMonkey instructions

Find your old profile

Your folders are stored as mbox files in a profile. These are text files with the folders name and no file extension. For example your inbox folder is the "inbox." file and the Sent folder is the "Sent." file. You can safely read one using a text editor to verify it contains mail messages though its not user friendly because it contains the raw message source, including all of the headers and big blocks of characters all run together whenever you have a binary attachment.

  • Go to your profile directory using Windows Explorer. If you're not sure you found a profile look for a prefs.js file and a Mail subdirectory.

If you're running Windows 2000 or later you may need to enable "Show hidden files and folders" and disable "Hide extensions for known file types" (its under the Hidden files and folders heading) and "Hide protected operating system files (Recommended)" in Tools -> Folder Options -> View to see it. You may get a warning message that your computer won't work if you do this. Changing those settings causes no harm, its really warning you not to change or delete any of the files or directories used to store the operating system. See this thread if you're running a older version of Windows.

Find the folders

If the folder was in Local Folders or you used a global inbox it will be somewhere in the Mail\Local Folders directory within the profile. Otherwise look for a subdirectory named after the accounts mail server. For example, if you're using a Gmail POP account your inbox would normally be the "inbox." mbox file at Mail\pop.gmail.com. If you have multiple accounts with the same email provider the subdirectory might have a numeric suffix, for example Mail\pop.gmail-2.com.

Ignore the .msf files, they don't have any messages. You want the files with the folders name and no file extension.

Thunderbird uses *.sbd subdirectories to create a folder hierarchy. So a Local Folders\1\2\xyz folder would be stored as a "xyz." mbox file at Mail\Local Folders\1.sbd\2.sbd\3.sbd . That directory would also have a empty xyz.sbd subdirectory created in preparation for you someday creating a child folder of xyz. Ignore it.

Import the folders

Your folders are stored as mbox files in a profile. These are text files with the folders name and no file extension. For example your inbox folder is the "inbox." file. DO NOT try to import "inbox.msf" or "inbox.sbd" - the messages are in "inbox.". That naming convention causes a lot of confusion, it would have been a lot easier if the mbox files had a .mbx or .mbox file extension like some other email clients use.

  • Select either the Local Folders directory or the POP account you want to import the folder into, in Thunderbird.
  • Tools -> ImportExportTools -> import mbox file
  • Browse to the mbox file and press the Open button.
  • Thunderbird will import that folder (mbox file). It may add a suffix to make the folder name unique. For example, when I imported "inbox." into Local Folders it created a inbox679 folder.
  • Repeat as needed. Note that you can import multiple folders (mbox files) in one step by holding down the Control key while clicking on them in Tools -> ImportExportTools -> import mbox file.

See also