MozillaZine

Import .pst files

From MozillaZine Knowledge Base

This article was written for Thunderbird but also applies to Mozilla Suite / SeaMonkey (though some menu sequences may differ).

Most import tools, and Thunderbird, require that a compatible version of Outlook be installed on the machine being used to import Microsoft outlook data. Microsoft Outlook stores data in .pst files, which is a proprietary format. Thunderbird does not understand that format, nor does it know that .pst files even exist. So there is no Thunderbird import command that lets you browse to the location of a .pst file, nor can it import data if Outlook is not installed.

Normally you import by setting Outlook as the default email client, and then use Tools -> Import -> Mail within Thunderbird. This method uses SimpleMAPI calls to Outlook, and Outlook accesses the contents of the personal folders (.pst) file. See this article for information on how to import from more than identity. If some of the messages aren't imported correctly, a common workaround is to import the messages into Outlook Express, and then import the messages from Outlook Express into Thunderbird.

Thunderbird is a 32-bit program, so it can't import from a 64-bit version of Outlook. Windows users can try mail conversion utilities, but they also make SimpleMAPI calls just like Thunderbird.

Alternatives:

  • If you just have the .pst file and can't install Outlook on the target PC you could:
  1. Install Thunderbird on another PC that has a compatible version of Outlook.
  2. Make Outlook the default email client.
  3. Copy the outlook.pst file to that PC and configure Outlook to use it. (may need to be in the default location)
  4. Compact the .pst file using Outlooks File -> Data File Management commands to permanently get rid of any deleted messages. Don't confuse this with compressing or zipping a file.
  5. Import the messages using Tools -> Import -> Mail. You can use Tools -> Import to also import the settings and address books.
  6. Repeat steps 3-5 as necessary for any other .pst files.
  7. Backup the Thunderbird profile. Mozbackup is a useful tool to do that.
  8. Restore the Thunderbird profile on your PC.
  9. Cleanup. (Uninstall Thunderbird on the PC with Outlook etc.)
  • If it is not practical to backup and restore a profile (perhaps one PC is using Windows and the other OSX) you could move it instead.
  • If you already created a new profile on your PC you could copy the profile from the other PC to it and then import its folders using either the ImportExportTools add-on (recommended) or the Local Folders add-on. That way you won't lose anything in your new profile.
  • Consider signing up for a free IMAP account with Gmail, copying the messages to the inbox on the IMAP server (IMAP lets you copy/move messages to/from remote folders as if they were local fodlers), and then let Thunderbird download them.
  • Use one of the operating specific solutions below. It includes a lot of solutions that don't work for most users, because it tries to be complete. You are usually better off installing one of the trial versions of Outlook and importing from it normally.

The type and version of .pst file, and version of Outlook you are using is important. You normally can't open an Outlook 2003 .pst file (it defaults to Unicode) in Outlook 2002 (which only supports ANSI). You could export it as a Outlook 2002 compatible .pst file in Outlook 2003 using the File, New, Outlook Data File command, and then choose Outlook 97-2002 Personal Folders File (.pst) as the storage type.

Folder names can also be tricky. Outlook doesn't care about mail folder names because it stores all of the folders within a single .pst file. Thunderbird however stores all of the messages for each folder in a file named after the folder. So characters in a folder name that are invalid filename characters for your operating system can cause problems when importing to Thunderbird. If you get an error message about Thunderbird being unable to create a folder you may need to rename all folders in Outlook to use 7-bit alphabetical ASCII characters and try again. Another possible problem is that you had two child folders with the same name under two different parent folders. Rename one of the child folders.

Thunderbird has no concept of Outlook identities or profiles, so it only imports from the default identity or profile. If you have multiple identities or profiles you need to set one as the default, import it using Thunderbird, and then repeat.

Contents

Windows

A 60 day trial version of Outlook 2010 is available here. The simplest solution is to install it, configure it to use the .pst file and then import the messages into Thunderbird using Tools -> Import -> Mail. If some of the messages don't import cleanly see this article.

PSTWalker is shareware that claims to be able to convert Outlook 97-2007 .pst files to MSG files, without using MAPI or requiring Outlook to be installed. The developers web site doesn't mention it, but this web site claims it requires .NET Framework 2.0. You could use a conversion utility (such as this commercial software or this ruby based utility) to convert the MSG files to either mbox or .eml files, and import them using the ImportExportTools extension. Nobody has mentioned using PSTWalker in the forums and its not on any of the major shareware web sites.

The Thunderbird PST Import plugin is a open source utility to import selected folders from a .pst file under both Windows and Linux. Its based on readpst. Some of the dialog boxes are in French. [1] [2] Its not clear how well it works since nobody has mentioned using it in the forums and most of the comments on the download site reports it doesn't work. [3]

Outlook2Mac is a inexpensive utility designed to "to move your Windows Outlook email, contacts, and calendar appointments from your PC to your Macintosh computer". It creates mbox files for the messages and vcf and/or vcard files for the contacts so that you could copy them to a Mac and import them into a email client that supports those standards. You could use the ImportExportTools extension to import the mbox files and the MoreFunctionsForAddressBook extension to import the vcard or vcf files. It requires you to have a copy of Outlook installed - you can't use it if all you have is the .PST file.

Google Apps Migration for Microsoft Outlook is a Google utility to upload mail, personal contacts, and calendar events from a .pst file to a Google Apps account. You could use those folders if you created a IMAP account for Google Apps in Thunderbird. The web page says you can use any Google Apps account though several blog posts claim its doesn't work with free (Standard Edition) Google Apps accounts. If you get a "This domain does not allow users to access the Email Migration API." error message that means you need to get the domain administrator to enable email migration for your domain, in order to upload.

Linux

There are several open source utilities to convert .pst files to mbox files such as readpst , libpst and Outport . Thunderbird uses a separate mbox file for each folder to store all of the messages for that folder. None of those utilities seem to be under active development and they only support some of the versions of .pst files. You can use the ImportExporttools extension to import the mbox files.

OSX

See if Microsoft offers a trial download of Office for the Mac or Entourage on their web site. The exact product name will change. For example, at one time it was called Microsoft Office 2004 for Mac Test Drive 11.0. Currently its Office 2008 for Mac Trial Edition for the Mac. It includes Entourage.

Microsoft's web site has a PST Import Tool for Entourage "to import PST files from Microsoft Outlook 2001 for Mac". Unfortunately there doesn't appear to be a version that supports later .pst formats. This article explains how to import folders from Entourage into Thunderbird.

The Entourage Import PST files help page has links to several products to import .PST files. It mentions Outlook2Mac, which can convert .pst files created by Outlook for Windows into files that can be imported into Thunderbird. However, it requires Outlook to be installed. The Convert Mail from Windows to Mac has some other suggestions/links.

If none of this help, you may need to buy a inexpensive commercial application that converts a .pst file to mbox files and the address books to .csv files. The ImportExportTools add-on adds support for importing mbox files to Thunderbird. Thunderbird has built-in support using for importing .csv or .ldif files in Tools -> Import -> Address Books -> Text Files.

  • LittleMachine's O2M is a commercial application for migrating Outlook data from a Windows PC to a Mac. It converts the files to formats such as mbox files and .csv files that Thunderbird can use. files. Unfortunately, O2M requires you have to Outlook installed.
  • PST Converter Pro is a similar commercial application but it explicitly states it doesn't require Outlook and that it can convert the files directly on the Mac.
  • The Personal Edition of Emailchemy has a demo version that "masks subject and sender fields in the converted email" that you could try first. Its user documentation states it supports "Outlook for Windows" but doesn't provide any details on what versions it supports. Their blog has an article about Using Emailchemy on corrupt PST files which confirms they read the .PST file directly, not though any Microsoft API's or connectors.

Misc.

There is also Xena, a Java application that can convert several types of files (including .pst) into a XML archive format for long-term digital preservation . They provide a viewer, but its not clear if anything is available to convert the XML archive format into mbox files.

If none of these solutions solve your problem see this article for some generic advice on how to import and export messages. Using a free IMAP account as an intermediary works well. If you're switching to a new PC where you're going to run Thunderbird (instead of Outlook) its recommended you import your messages into Thunderbird before getting rid of (or cannibalizing) your old PC.

If you have problems importing messages using mixed Western and Asian fonts see [4]

If you get an error message that says Thunderbird can't write to the folder (while importing) check that the TEMP environmental variable points to a folder on your hard disk that has enough room to store a temporary copy of all of the messages.

Contacts

If your Outlook contacts are in the Personal Address Book they're stored separately in a .pab file. If they're in the Outlook Address Book they're stored in the .pst file.

The easiest way to import contacts from a .pst file is to install the trial version of Outlook, export them as a .csv or .ldif file, and then import them using Tools -> Import -> Address Books -> Text Files. If you don't want to do that you could try exporting them as .vcf files using the trial version of Recovery Toolbox for Outlookand then import them using the MoreFunctionsForAddressBooks add-on.

See also

External links