MozillaZine

Import bookmarks

From MozillaZine Knowledge Base

This article explains how to import bookmarks from an HTML file or from another browser into Firefox or SeaMonkey. The imported bookmarks will be added to the current bookmarks.

Contents

Import from file

You can use the Import feature of the Bookmarks Manager to import bookmarks stored in an HTML file:

  • Mozilla Suite/SeaMonkey 1.x: "Bookmarks -> Manage Bookmarks -> Tools -> Import"
  • SeaMonkey 2: "Bookmarks -> Manage Bookmarks -> Tools -> Import -> File"
  • Firefox 2 and below: "Bookmarks -> Organize (or Manage) Bookmarks -> File -> Import -> From File"
  • Firefox 3 and above: "Bookmarks -> Organize Bookmarks (or Show all Bookmarks)-> Import and Backup -> Import HTML... -> from an HTML File"

Browse to the folder containing the bookmarks HTML file, select the file you wish to import and click "open". The imported bookmarks will be added to your existing bookmarks.

Firefox users who don't wish to keep their existing bookmarks can start in Firefox Safe Mode, select the option, "Delete all bookmarks except for backups" (Firefox 3.6 and above) or "Reset bookmarks to Firefox defaults" (Firefox 3.5 and below), and then choose "Make Changes and Restart", before importing the bookmarks HTML file.

You can import a bookmarks file from a number of different sources, as long as the file is in HTML format. Examples include:

On Windows and Linux, the profile folder for Mozilla applications is hidden by default. See this article if you need help viewing or searching for hidden files and folders.

Note: In Firefox 3, imported bookmarks are added to the end of your Bookmarks Menu. This means, for instance, that bookmarks from exported Firefox 3 bookmarks will have the imported bookmark folders (Bookmarks Toolbar, Bookmarks Menu, and Unsorted Bookmarks) added to the end of the existing Bookmarks Menu and you will have to check the nesting and move wanted imported bookmarks where you want them and remove any unwanted folders and bookmarks left over from the import. To restore your Firefox 3 bookmarks to a state before the import you can use the "Import and Backup -> Restore" option in the Library window and select an available backup.

Import from another browser

Firefox includes an Import Wizard that can be accessed via "File -> Import". You can use the Firefox Import Wizard to automatically import bookmarks and other data from installed browsers such as Internet Explorer, Opera, and Netscape 6-7-Mozilla Suite (which includes SeaMonkey 1.x). Only use the following instructions in Firefox if the Import Wizard doesn't work.
Note: If you use Firefox 3.5 or newer in Private Browsing mode then the "File -> Import" item is grayed and not available.

From Internet Explorer

On Windows, Mozilla Suite and SeaMonkey will automatically import Internet Explorer "Favorites" when first installed and (in Mozilla Suite/SeaMonkey 1.x) whenever you create a new profile.

You can manually import your IE Favorites but you have to first use Internet Explorer to export the Favorites to a file, then use the Mozilla Suite SeaMonkey or Firefox Bookmarks Manager to import it.

To export your IE Favorites to a file

  1. Open Internet Explorer
  2. Press the "Alt" key to show the IE menu toolbar, if the menu bar is hidden (File, Edit, View, Favorites, Tools, and Help menu items).
  3. In the IE menu bar, go to "File -> Import and Export..."
  4. Follow the prompts to export your IE favorites to a file, which will be named "bookmark.htm" by default.
  5. After you've finished exporting your IE Favorites to a file, use the Mozilla Suite/SeaMonkey or Firefox Bookmarks Manager and import the file.

Note: Specific steps to export your IE Favorites to a file will depend on your IE version. Check Internet Explorer Help (from the IE Help menu) or read this article.

From MSN Explorer

Go to the "Convert bookmark file" web page at http://www.linkagogo.com/go/Convert?informat=msn&outformat=netscape to convert the MSN Explorer file "favorites.xml" (input format) into a "Netscape (also Mozilla and Firefox)" HTML file (output format) . (If you have problems locating the "favorites.xml" file on your computer, read the "MSN Explorer users" section of the web page and this article.) After converting, use "File -> Save Page as" to save the output. You can then import the HTML file you just saved into your Mozilla browser using the "Import from file" feature of the Bookmarks Manager (see above). You can alternately try the MSN Favorites Export Toolkit, available from http://www.mainsoft.fr/en/downloads.htm to convert the MSN Explorer file (favorites.xml) into a Netscape bookmarks file (bookmark.htm) which you can then import into your Mozilla browser (details here).

See this MozillaZine forum thread for additional information.

From Netscape Navigator 9

Use the "Import from file" feature of the Mozilla Suite/SeaMonkey or Firefox Bookmarks Manager as explained above, to import the "bookmarks.html" file from the Netscape Navigator 9 profile folder. On Windows 2000/XP, the profile folder is located here:

  • C:\Documents and Settings\<Windows login user name>\Application Data\Netscape\Navigator\Profiles\<Profile name>

See the Netscape release notes for other Navigator 9 profile folder locations. Important: On Windows 2000/XP/Vista and Linux, you will need to show hidden files and folders.

From Netscape 8

Use the "Import from file" feature of the Mozilla Suite/SeaMonkey or Firefox Bookmarks Manager (explained above) to import the "bookmarks.html" file from the Netscape 8 profile folder. On Windows 2000/XP, the Netscape 8 profile folder is located here:

  • C:\Documents and Settings\<Windows login user name>\Application Data\Netscape\NSB\Profiles\<Profile name>

Important: On Windows 2000 and later you will need to show hidden files and folders .

From Opera

If Firefox Import Wizard doesn't work, you can use a third-party bookmarks manager like Bookmark Converter (alternate link) to import your Opera bookmarks and export them back out as a HTML file. You can then import the bookmarks HTML file into Firefox or Mozilla Suite by using the Import feature of the Bookmarks Manager, as explained above.

From Safari

Firefox imports Safari settings automatically. Just go to File > Import... and select Safari. In the next window, check the boxes of what you want to import. For example, your Safari Bookmarks will appear in Firefox's Bookmarks menu as "From Safari." Whatever other bookmarks you had on your Safari Bookmarks Bar will automatically appear on your Firefox Bookmarks Bar, too.

Other possibilities, if you're using older versions of Firefox, Mozilla Suite and/or Safari, are given below.

You need third-party software to export Safari bookmarks such as Safari Bookmark Exporter (works with Mac OS X Tiger) [1] [2].

But why use software when you have what you need, activate Debug...
Quit Safari and launch the Terminal.
Enter this in the Terminal window:

defaults write com.apple.Safari IncludeDebugMenu 1

This adds a Debug menu to Safari.

Launch Safari and from this self-same Debug menu choose Export Bookmarks and save the resulting Safari Bookmarks.html file to a convenient location.

Launch Firefox or Mozilla Suite and import the bookmarks file as explained above. In Firefox, choose Manage (or Organize) Bookmarks from the Bookmarks menu. When the Bookmarks Manager window appears, choose Import from the File menu. In the resulting sheet, choose From File and click Next. In the Import Bookmark File dialog box that appears, navigate to your saved Safari Bookmarks.html file and click Open.

From SBC Yahoo! Browser

How do I import/export my bookmarks?

From Avant Browser

Avant Browser uses the same Favorites as Internet Explorer [3] [4] so you would open Internet Explorer, go to "File > Import and Export...", then click Next and export your IE Favorites to an HTML file, as explained above. Then you would import that file using the "Import from file" feature of the Mozilla Suite/SeaMonkey or Firefox Bookmarks Manager (see above).

From AOL 8 or 9

Use this widget http://www.linkagogo.net/go/Convert?informat=aol&outformat=netscape

From Google Chrome

In Google Chrome, click the "Tools" menu and select "Bookmark Manager". In the Bookmark Manager, click "Tools -> Export bookmarks". Choose a name and location for the bookmarks file and click "Save". Google Chrome will export your bookmarks as an HTML file. (e.g., "bookmarks.html"). [5] You can then import that file using the "Import from file" feature of the Mozilla Suite/SeaMonkey or Firefox Bookmarks Manager (see above).

See also

External links