MozillaZine

Duplicate messages received

From MozillaZine Knowledge Base

This article was written for Thunderbird but also applies to Mozilla Suite / SeaMonkey (though some menu sequences may differ).

Some people have experienced problems with Thunderbird receiving duplicate messages when downloading mail. In other words, messages that already exist in one's Inbox (or elsewhere locally) are downloaded again. Typically the duplicates appear in one's Inbox as unread messages. Depending on the user, it may happen always when downloading, only sporadically, or perhaps one time only. It may happen with some mail servers but not others, after a previous mail download that was interrupted (for instance, if Thunderbird crashed while downloading), or after reinstalling Thunderbird.

Deleting duplicates

Some ways to delete duplicates:

  • If you have received a huge amount of duplicates all at once, one way to remove them from your Inbox is to sort messages by the order they were received ("View -> Sort by -> Order Received"). Since the duplicate messages were all received at once, this should group them together in the message list. You can then select all of them together and send them to the Trash folder.
  • If the duplicate messages appear as unread and are not mixed among unread messages you want to keep, use the "View" pulldown menu and select "Unread." This will give you only unread messages in the main listings window. Then select all, either from "Edit -> Select -> All" or by pressing "Ctrl+A". Once the group has been defined, delete the whole batch at once with "Delete."
  • The folder might be badly corrupted. See this article for how to replace it (while keeping the messages).

To avoid receiving further duplicates

There is no sure-fire method to ensure that you will never receive duplicate messages again, but below are some things you can try, with the easiest options listed first.

  • Set Thunderbird to delete messages from the server: go to "Tools -> Account Settings -> Server settings", and uncheck "Leave messages on server."
  • Compact folders, exit Thunderbird, and go to your mail folders (in your profile folder). Delete the index files, named "*.msf" (such as "Inbox.msf"). These will be rebuilt when your launch the application again. (You should not need to do this on a regular basis, however.)
  • Try deleting the popstate.dat file from the account subfolder in the "Mail" folder in your profile folder. If "popstate.dat" gets corrupted Thunderbird can get confused about what has been downloaded. (Note: if you delete "popstate.dat" and you still have messages on the server that have already been downloaded once, they will all get downloaded again.)
  • If you share your mails with Windows/linux viaThunderbird (prefs.js tip), and you always get the leaved message again, ensure you've removed all the relative paths in the prefs.js you've modified.

Of course, if you try deleting files or making a new profile, it's wise to first make a temporary backup of your mail and settings.