MozillaZine

Dictionaries

From MozillaZine Knowledge Base

This article was written for Firefox and Thunderbird but also applies to SeaMonkey 2.

This article is about dictionaries used to check spelling in Firefox and Thunderbird. It applies to releases of these applications starting from 2.0. For information about dictionaries for Thunderbird releases before 2.0, see: Obsolete Dictionaries - Thunderbird

Notes: 

  • Localized builds of Firefox or Thunderbird, or a language pack, often do not not include a dictionary for the language. You may need to install a dictionary for spell check to work.
  • The spelling checker does not support all languages.
  • You can install an extra dictionary when you want to be able to check spelling in an extra language or in a regional variant of a language.
 

Contents

Installing a dictionary

Sources

Add-on (extension) dictionaries are easier to install than other dictionaries. Dictionaries are available from these locations:

Installing directly via Add-ons

Installing via Tools | Add-ons is the easiest method, but only works for add-on dictionaries. Use this method to install a dictionary in the current profile. To install the dictionary in another profile, switch to that profile and repeat the procedure:

    Firefox:
    1. On the web page, click the link that points to the dictionary.
    2. When a Software Installation dialog opens, wait three seconds for the Install Now button to become enabled, then press it. Firefox downloads the dictionary.
    3. When the download is complete, press the Restart Firefox button in the Add-ons window. Firefox closes and restarts.
    Thunderbird:
    On the web page, do not click the link that points to the dictionary.
    1. In Thunderbird, choose Tools – Add-ons. Thunderbird's Add-ons window opens.
    2. From the web page, drag the link that points to the dictionary and drop it in Thunderbird's Add-ons window.
    3. When a Software Installation dialog opens, wait three seconds for the Install Now button to become enabled, then press it. Thunderbird downloads the dictionary.
    4. When the download is complete, press the Restart Thunderbird button in the Add-ons window. Thunderbird closes and restarts.

Installing by downloading manually

This method only works for add-on dictionaries. Use it when you want to download the dictionary just once and install it in more than one profile.

To install the dictionary in another profile, switch to that profile and repeat the procedure from step 2.

  1. From the web page, get a context menu for the link that points to the dictionary (for example, by right-clicking it). From the context menu, choose Save Link As... and choose where to save the downloaded file on your computer. You can save it in a temporary directory or on your desktop.
  2. Firefox — either:
    • Use your mouse to drag the file that you downloaded and drop it in Firefox.
    or:
    • From the Firefox's menu bar, choose File – Open File..., then choose the file that you downloaded.
    Thunderbird:
    a. From Thunderbird's menu bar, choose Tools – Add-ons. Thunderbird's Add-ons window opens.
  3. b. Either:

    • Drag the file that you downloaded and drop it in Thunderbird's Add-ons window.
    or:
    • Press the Install... button and select the file that you downloaded.
  4. When a Software Installation dialog opens, wait three seconds for the Install Now button to become enabled, then press it. The application installs the dictionary.
  5. Press the Restart Firefox or Restart Thunderbird button in the Add-ons window. The application closes and restarts.
  6. Optionally delete the file that you downloaded.

Installing by using an extension

This method is only for Thunderbird and works for all dictionaries. Use it to install a dictionary that is not packaged as an add-on, or when you want to make the dictionary available in all profiles.

First install the Dictionary Fix extension. To install dictionaries, follow the instructions on that linked page.

Note:  You can use other extensions that work with add-ons to install add-on dictionaries in both Firefox and Thunderbird—for example: MR Tech's Local Install

Installing manually to the application

This method works for all dictionaries. Use it to install a dictionary that is not packaged as an add-on, or when you want to make the dictionary available in all profiles.

This method installs the dictionary in the application itself, making it available in all profiles (but see the note below).

At step 5 you usually need a program to open the downloaded file. You can use any zip tool or jar tool—for example: 7-Zip

  1. From the web page, get a context menu for the link that points to the dictionary (for example, by right-clicking it). From the context menu, choose Save Link As... and choose where to save the downloaded file on your computer. You can save it in a temporary directory or on your desktop.
  2. From the menu bar in the application's main window, choose File – Exit. The application closes.
  3. Go to the application's installation directory. (You can often find it by looking at the properties of the shortcut or launcher icon that you use to start the application.)
  4. Go to the dictionaries directory there. (If this directory does not exist, just create it at the same level as the components directory)
  5. Use a zip or jar tool to open the file that you downloaded. (If the file extension is .xpi, then some zip tools require you to rename it .zip first.)
  6. Store the .dic, .aff and README- files in the dictionaries directory.
  7. If the .dic and .aff files you stored do not have names like xx-XX.xxx or just xx.xxx, rename them. (For example, rename en_US.aff as en-US.aff or just en.aff.)
  8. Restart the application.
  9. Optionally delete the file that you downloaded.

Note:  To install a dictionary manually in a particular profile, at step 3 go to the profile directory. Then at step 4, create the dictionaries directory, if necessary, at the same level as the extensions directory. You might want to do this, for example, if the profile is shared by more than one installation of Thunderbird.

Uninstalling a dictionary

To uninstall a dictionary that you installed as an add-on:

  1. Choose Tools – Add-ons.
  2. Select the dictionary.
  3. Press the dictionary's Uninstall button, then confirm the uninstall.
  4. Restart the application.

To uninstall a dictionary that you installed manually:

  1. Delete the files that you installed.
  2. Restart the application.

Selecting an installed dictionary

Related preference: Spellchecker.dictionary

Firefox:

After you install a new dictionary, you need to select that dictionary if you want to use it. You can do that by opening the context (right-click) menu of a text area, selecting "Languages" and choosing the dictionary you would like to use. The "Languages" sub-menu shows all installed dictionaries and includes an item ("Add dictionaries") to install new dictionaries from addons.mozilla.org. The context menu also has an item ("Spell check this field") that shows if spell checking is enabled. The Dictionary Switcher add-on adds a toolbar button that can also be used to switch the spellchecker dictionary.

Spell checking can be enabled or disabled using the checkbox, "Check my spelling as I type" in "Tools → Options → Advanced → General / Browsing". You can change the preference layout.spellcheckDefault in about:config directly to enable spell checking for single-line and multi-line text fields.

Thunderbird:

You can choose the spelling checker’s language in: “Tools → Options → Composition → Spelling → Language”. You can also choose it in the Compose window using either : “Options → Check Spelling... → Language” or by pressing the Spelling button and choosing a dictionary from the list box.

The Markov dictionary switcher add-on detects the language of the message that you are composing after you type four or five words and changes the spelling dictionary. The Automatic dictionary switching add-on remembers the language the spellchecker used when composing a message to somebody and automatically switches to it every time you write to that person.[1]

Spelling errors / Dictionary changes

The contents of dictionaries are not maintained by Mozilla. In some cases they are not maintained by anyone. If you think the contents of a dictionary should be updated, you might be able to find out who maintains it by looking in its README file (if it has one). You can find the README file by using a zip tool or jar tool to open the dictionary's installation file. .xpi files can be opened in windows explorer by first changing the .xpi extension to .zip

Until a spelling error is fixed by the maintainer, you can add what you consider to be valid words to your personal dictionary.

The Auto Correct add-on autocorrects words and automatically capitalizes the first word of a sentence. It has its own autocorrect list which you can edit.

Personal dictionary

Your personal dictionary is stored in the file persdict.dat in your profile folder. It is simply a list of words in plain text format that you added via the spell checker or by importing. To delete custom entries added to the spell check dictionary, you can manually edit the file persdict.dat in your profile folder.

You can import a list of words from somewhere else by replacing this file, or you can copy this file to use it in a different profile.

Troubleshooting

Note:  In Thunderbird 2, the Dictionary Fix extension automatically fixes some common problems with dictionaries.

Common problems:

  • Dictionary not compatible with your version of the application. Either download a compatible version, or install the dictionary manually.
  • You did not close the application completely. Choose File – Exit from the main menu bar to ensure that all the application's windows close.

Less common problems:

  • You installed a Thunderbird dictionary in Firefox by mistake. Either download the Firefox dictionary, or install the Thunderbird dictionary manually.
  • Users do not have permission to read manually-installed dictionary files. On a multiuser system, ensure that all users have read access to the files specified in the Installing manually section above. For example, on a Unix system use chmod to set these files' permissions to 644.
  • The dictionary is faulty. Try a dictionary from another source.
  • You installed the application without removing an older version, and the application did not install correctly. See the section Installing manually above. At step 4, if the dictionaries directory is missing, then your installation failed. Try creating the dictionaries directory manually. You might be able to move dictionary files into it from the obsolete chrome/myspell directory, if it still exists.

Odd problems:

  • The spelling checker sometimes finds strange words that you do not see in the message—for example, "msonormal". This happens when HTML is generated by a Microsoft product that inserts hidden text. If it happens when you write new messages, the hidden text is in your signature file. If it happens when you reply, the hidden text is in the original message.

External links