MozillaZine

Adobe SVG Viewer

From MozillaZine Knowledge Base

Contents

Native SVG support

Starting with Firefox 1.5 and SeaMonkey 1.0, Mozilla products have native SVG support, which means that the Adobe SVG Viewer plugin is not required in most instances.

Installation

Microsoft Windows

Microsoft Windows users will need to use Adobe SVG Viewer 6.0 Build 38363. This is an alpha release, and may be unstable.

The Adobe SVG Viewer installer does not allow you to pick a location to install the plugin in, nor does it detect Mozilla based browsers. To install it, you will need to copy NPSVG6.dll and NPSVG6.zip to your browser plugins folder. These files are located in C:\Program Files\Common Files\Adobe\SVG Viewer 6.0\Plugins\ on most systems.

Linux (x86)

The only version of Adobe SVG Viewer that works on Linux is Adobe SVG Viewer 3.01 Build 88. This is a beta release, and may be unstable.

As root, extract the contents of the installation package and run the script adobesvg-3.01/install.sh. Adobe recommends that you extract the files in /usr/local, although other locations may work. After doing this, copy libNPSVG3.so to your browser plugins directory.

Issues

  • All versions of Adobe SVG Viewer prior to and including 3.0 will cause Mozilla and Firefox to crash.
  • The mousemove event does not work on Mozilla browser also - looks like Family feature. Try to drag magnifier http://www.svgcomposer.com/gallery/2.php
  • Linux Only: It has been reported that if the LC_NUMERIC variable is not set to en_EN this plugin may not work correctly.

See Also

External Resources